cydie
1 Copper

Aurora R5 some USB ports not working

Hi,

I noticed often that my keyboard will sometimes disconnect or not respond (default lights on sometimes) and won't work unless I unplug and plug it back in.

Today I noticed that it wasn't responding at all, and when I replugged the entire thing in, tried it, didn't work, restarted my PC, unplugged it, tried it, didn't work, I then plugged my mouse into the first USB port.

The port seems to be entirely dead. No lights come up on the mouse, no USB detected. All other ports seem to be working fine, save for the first 2.0 port on the back, and the first 3.0 port on the back.

The first 3.0 port seems to be going out the same way, disconnecting here and there, needing to unplug and replug back in. I had a hard drive in the first port, but I've moved it to the second port and I haven't had to unplug it at all.

Windows is up to date, I reinstalled my OS a few months ago, the SSD I put in a few weeks ago disconnected once, and I had to unplug that and plug it back in. It almost seems like the motherboard isn't having a good time.

What could be causing this issue, and how can I find it?

Tags (2)
0 Kudos