1 Copper

Aurora R7, unable to upgrade to 64GB RAM

So I purchased this machine about a year ago on Dell's site. And after a while, I wanted to upgrade my RAMto 32GB, but the model was too new to have the same model of the RAM (HyperX Fury 2933). So then I went to Kingston's HyperX site and bought 2 x 16 GB Predator 3000. It works like a charm, can be OC to XMP2, the only disadvantage is that it only works under 2666 not 2933 or 3000. Recently I want to upgrade again from 32GB to 64GB, so I bought another 2 x 16 GB HyperX Predator 3000. Then, when I tried to put in 4 Predators, then the pc gives me 4 yellow blinks, indicated that there's a memory failure. Then I tried to put them in individually, all RAMs work perfectly fine. I called Dell Customer Support and told them that the motherboard may be defective, but they just said that because the RAMs are not purchased from them so they cannot help.

I think that 4 x 16 GB of HyperX Predator should work, but it doesn't. Anybody have some solutions to try or explanations to say why it doesn't work? I've already checked that my BIOS version is the newest one.

Here's the picture of Predator 3000 working perfectly fine under XMP2mfSghql


0 Kudos