1 Nickel

WiFi Card drops connection and reconnects constantly


Hey guys,

first of all, thank you for reading my post. I got a massive problem with my Alienware Area 51 R2.

For some reason, after nearly 3 years of constant performance and no hardware problems at all, the WiFi card of my Area 51 keeps losing Internet Connection.

The strange part is, that the connection to my router is still intact, but the Internet access gets crossed out. I also have a notebook, an iMac and an iPhone connected in the same network and every device works just fine.

To check furthermore that my router is fully functional, I tested a LAN connection on the Area 51 and the connections drops disappeared.

Back to WiFi: I searched in some forums and there are some people who seem to have the same problem like me. For example: Alienware Forum - Killer wifi keeps losing internet connection

What I already tried is:

  •  installed latest driver from KillerNetworking (v.1.6.2149) x64
  • deactivated and activated Wifi Card in device manager
  • deactivated IPv6 (altough it worked 3 years with IPv6 settings on)
  • Power Management -> disabled "Allow computer to turn off this device to save power"

To make it as understandable as possible, I'll try to list the scheme of the problem:

1. WiFi Connection is "stable"

2. Suddenly the current application stucks because the PC has no connection to the Internet. After 10 secs, the WiFi symbol gets crossed out. Windows displays that I'm still connected to the router, but there is no Internet connection. (every other device is still connected and has internet connection though)

3. For 1 sec, the crossed out WiFi symbol changes to a crossed out Ethernet connection Symbol (like I had a LAN cable connected, with connection to the router, but not Internet connection)

4. And 5 secs later, the WiFi symbol pops up again and the Internet connection is back again.

5. Repeat multiple times a day

I can confirm that the connection drops are not coming more frequently when the download/upload-traffic is high. The connection drops in an idle state on the desktop of Windows as well.

Do you have any ideas? Do you think it's a hardware defect?

Keep up the good work!

Best regards,



My system:

CPU: Intel® Core™ i7-5820K
OS: Windows 10 Home x64