TomC69
1 Nickel

Re: BIOS update not installing.

My new 17 R4 bought on after-xmas sales just over 2 months ago came with 1.2.3 installed.  Fortunately I was able to follow the esc/ctrl roll-back instructions below and this ended up taking it back to 1.1.9.  I then updated this to 1.2.1.

1. shutdown your laptop.

2. unplug the power cable.

3. Hold down the ESC key and CTRL key.

4. Plug in the power cable whilst still holding the ESC and CTRL keys down.

5. Press the power on button.

6. When it starts to boot, fans etc come alive, release the ESC and CTRL keys.

7. It will boot to a bios page where you can select ROLL BACK BIOS

8. Press the arrow keys to select this option and press RETURN

9. Let the pc do its thing and it will eventually restart and when windows boots if you right click the widows key, click on run and type in dxdiag and hit return you will see what bios you are at and it should be back to 1.2.0 or 1.2.1.

You can now run support assist if you arent on 1.2.1 and update to the latest stable bios.

 

Going to 1.2.1 improved my Windows mixed reality VR performance significantly (~15% higher fps) and this worked great.  Then I got the notification from dell that 1.2.4 was available and that this was an Urgent update due to the new intel security features.  So I did this and now my performance is back down to where it was with 1.2.3.  

I tried the roll-back method I used before but this refused to allow me to roll-back.  I think that there is some security feature that stops this from happening.  Needless to say I am not very happy with all this and I can only hope that Dell provides me some way to get back to 1.2.1, but I kinda doubt that's going to happen.  Maybe future updates will improve this, ha-ha!