somtwift
1 Copper

Re: 15 R2, stops charging under load and games crash

You may have the same problem I had with my Alienware 15 R1. Same symptoms. Tried everything on forums and internet. New battery, new 330w power supply, replaced DC internal connector, updated BIOS etc. Never fixed it BUT . . . I found a workaround for my problem. In Device Manager under battery you will find Microsoft ACPI-Compliant Control Method Battery. Disable it and keep it disabled. You will lose your little battery charge state icon on your task bar but it will still charge. Charge your battery to 100%.  I went from EVERYTHING at EVERY SETTING stuttering, to all AAA games running in ULTRA. Was able to step down to my Alienware M14, 150W power supply and keep it running and charging at the same time. If you want to check your battery status just re-enable and check it. Be sure to disable it again before leaving.  I expect there are a lot of people out there changing parts that won't fix this problem.  Easy to try . . . of course your miles may vary.

0 Kudos