fixerupper1
1 Copper

Re: Empty optical drive ejects randomly (every 2-15 mins)

A customer brought their DELL Studio 1535 in for a couple of problems, one of which was the CD eject problem referred to in this discussion. After fishing around online and trying all the software-related fixes (BIOS update, appropriate optical drive Firmware update), I removed the Center Console cover (or Media Center panel) and looked at the underside of it. I discovered that the flat, 10-pin cable had been folded in such a way that the fold nearest to the connector on the underside of the panel was too close to the connector, and pressure from pushing on the panel from above had compromised (or traumatized) the ribbon cable and the insulation (plastic covering of the cable) had been cut, exposing the wire in the cable. Since these units are probably assembled pretty much the same, your problem may be caused by the same cable-trauma. What I did to fix it was I took my spudger (nylon probe tool, in my case made by Menda) and used it to smooth out the cut area from the other side of the cable, directly behind where the cut was. I just laid it over on the smooth plastic underside of the panel and stroked it a few times with the flat end of the spudger, which apparently was enough, in my case, to fix the problem.

However, if your cable won't play ball, you will need (for DELL Studio 1535 and related DELLs) a Tennrich AWM 20624 80C VW-1 10-pin ribbon cable, about 5.5" to 6" long. I found some new ones on eBay. See the DELL support site for your service manual (enter your service tag for best results. An easy fix for a vexing problem.

0 Kudos