calebtrask
1 Copper

Just "installed" Radeon R7 250 graphics card on my Dell Optiplex 9020. Black screen when I plug the monitor into the card. Help!

Hi Yall,


So I have successfully (I think) installed my new Radeon R7 250 "low profile" graphics card on my Dell Optiplex 9020.  I plugged it in the motherboard, started up the computer then went to Device Manager to update the drivers--which I did.  Side note: Ever since plugging the graphics card into the motherboard, some tasks like starting programs or starting windows take 2-10X as long as they used to.  Anyhow, it then asked for a restart, which I did.  The computer still took extra long to start any program, and when I plugged the monitor into the graphics card all I got was a black screen. 

Take two:  I then read that I should have uninstalled my current graphics driver (Intel integrated HD graphics) before I installed my new graphics card, but failing this, I could uninstall my old graphics card and change the default graphics card in the bios.  I uninstalled the old card and went to the bios, but could not change the default...can't remember exactly what it called it, graphics controller or something.  I could see that intel HD graphics was still the default (this is after uninstalling intel HD graphics and then restarting) but could find no way to change this.  Supposedly dell will make the switcheroo on its own...but it doesn't seem to have. 

Take three:  Next I physically removed the graphics card, restarted the computer, then physically inserted the graphics card again, then started the computer again (no, I did not insert the card while the computer was on). 

I'm not sure what else to try.  The computer still starts programs exceedingly slowly and still gives me a black screen when I try to plug the monitor into the graphics card--which the computer recognizes as existing in the Device Manager.  What is more, the Intel HD graphics card that I uninstalled appears to have reinstalled itself as it is now visible again in the Device Manager plus it has the little control program accessible from the "hidden icons" popup menu off of the toolbar in the lower right-hand corner. 


I can't help but think that if I could get the bios to prefer the radeon card I'd be set--but I don't see an option for this.  Help?

0 Kudos