1 Copper

XPS freezes on BIOS POST

I have a Dell XPS710 (see system specs at the bottom)

1.  When I booted Monday the system froze one third through the BIOS POST screen

2. I unplugged every cable including USB mouse and USB keyboard (but left the monitors) and the system booted (albeit with keyboard missing error).  I was able to plug in the keyboard, mouse and ethernet cable and had a functional compter (so the problem is not the hard drive or the motherboard)

3.  I powered down and then restarted with just the USB keyboard in and it froze at the same place as #1.  I noted then the diagnostic lights on the front: 2, 3 and 4 were green indicating "A possible USB failure has occurred. Reinstall all USB devices and check all cable connections."  Duh.  Codes are here.

4.  Thinking the problem might be the BIOS, I powered up as in #2 and went to and flashed the BIOS (Rev 1.4.1, same as before).  Computer shut down as it always does and then froze at the same place (since the USB keyboard was plugged in).  I was able to reboot as in #2 after that so BIOS doesn't seem to be it.

5. Now this is where I (nearly) went wrong.  I decided to clear the CMOS.  Powered down the system, moved the jumpers on the motherboard from PASSWORD to RTCRST and back as described in the Service Manual and then rebooted.  System still froze with the USB keyboard in.  So I took the keyboard out but now the system won't boot because it thinks I have a missing floppy drive (I reset the BIOS remember!!!! ARRRGGGHHHH).  I get the Dell infamous "Alert! Previous attempts at booting this system have failed at checkpoint [Ithr].  For help in resolving this problem please note this checkpoint and contact Dell Technical Support" error.  The system says hit F1 to continue but I can't since it won't boot with a keyboard attached.  Talk about a catch-22!!  So I no longer can get back to a functional computer in #2.  Am I stuck?  Do I have to call Dell Tech Support?  But wait, our intrepid hero has an idea….

6. So I borrowed a PS/2 keyboard from a friend.  The computer doesn't choke on it.  I reboot and am able to hit F2, get into system setup and turn off the floppy controller.  Disaster averted.  While I'm there I checked all the other BIOS settings and they are all at the factory defaults.  The only system setup relating to USB is "USB Controller" which is at the default: ON.  I exit Setup, system boots and passes POST with only the PS/2 keyboard plugged in and I'm back to #2.

7. Running out of ideas I ran over to Radio Shack and bought a new CR2032 battery.  Can some one explain to me why something the size of a nickel and the technological equivalent of a toaster costs $6? I took out the battery from the motherboard, waited 15 minutes and put the new one in.  I booted with the PS/2 keyboard, got the same floppy drive error as in #5.  Then I went into setup, changed the time and turned off the floppy controller and was able to boot as in #2.  Powered down, plugged in a USB keyboard and…. no love.  Still freezes at the POST screen; still shows diagnostic lights 2, 3 & 4.

So I'm out of ideas and looking for help.

In particular is there a way to diagnose a problem with the USB controller or the USB ports?

Is it worth it trying to remove the hard drive, DVD drive, sound card and other peripherals?  Seems to me that being able to boot as in #2 counts them out?

Have I really eliminated a problem with the motherboard?

As an aside I have not recently added any new hardware or installed any new software.  I have tried plugging the USB keyboard into the port next to the NIC in the back and there is no difference.

XPS 710
Intel Core 2 Duo E6600, 2.4gHz 4MB CPU,
4G RAM (1G x4)
Nvidia GeForce 8800 768mb video card 
Sound Blaster X-Fi Xtreme Sound Card 
500 GB SATA Hitachi hard drive
Windows Vista 32 bit


0 Kudos
1 Copper

Re: XPS freezes on BIOS POST


So when we left our hero, he had a working computer so long as no USB devices were plugged in while the machine POSTed.  Does he have to live with plugging the keyboard in after each time?  So here's what he (I) tried last night.

8.  Brand new USB keyboard in three different USB ports.  No love.  Keyboard was a Logitech 967738-0403, about as plain jane as they come.  Tried in USB ports in the front and both the upper and lower tier in the back.  

9. Disable the USB from the boot order.  Has anyone ever successfully booted from a keyboard?  What are you supposed to do - type in machine code?  Anyway, no love.

10. Tried disabling the Vista device drivers for USB.  Deleted & reinstalled.  No love.  In retrospect, given the hard drive hasn't even started spinning, its unlikely to be the Vista drivers.  But, still, no love.

11. Now this is interesting.  Tried booting with a USB printer (HP Laserjet 1022) plugged in.  And it booted fine.  How very odd.  Is this a clue?  I don't know if this is important or not.

I don't really want to live with a PS/2 keyboard as I use a Microsoft ergonomic keyboard that is easier on my hands and a 5 button Logitech mouse that has a nice weight to it.

0 Kudos
1 Copper

Re: XPS freezes on BIOS POST


12.  So I learned something new last night.  It is NOT that the printer is ok.  It turns out that that one USB port is ok.  There are 8 USB ports on the machine.  A row of four in the back (Hub#1 Ports #1-4), 2 immediately below next to the NIC (Hub#1 Ports #5&6) and then two in the front (Hub#1 Ports #7&Cool.  If the USB keyboard is plugged in to #1, then it boots.  

14. And here is another clue.  In Vista, if I go to device manager (DM) I see the following 
 - USB Enhanced Host Controller
 - Standard Enhanced PCI to USB host controller
 - Unknown Device

What is interesting, is that the "Unknown Device" shows up even when there is nothing plugged in.  I tried reinstalling and then just disabling it to see if that fixed the problem and it doesn't.  Also note that the Unknown Device does not have a yellow question mark in the DM.  In fact it says it is working properly.  Philosophically, how do you know it is working properly if you don't even know what it is?

Also note that, per #10 and again last night, I disconnected all USB devices; uninstalled all of the USB drivers in the DM, rebooted and reinstalled the drivers. The Unknown Device showed up again after reinstalling. Physical examination of port #2 doesn't look any different than any of the others.

So basically Port #1 works; Port #2 is haunted and Ports #3-#8 only work after booting.

Is this another example of a poor quality Dell motherboard being the root of all evil?  Or is that the "hub" of all evil?  I did try Dell technical support and they were more interested in my credit card number than my problem.

0 Kudos
1 Copper

Re: XPS freezes on BIOS POST

15. For those who have been following the saga this is the penultimate entry.  I left my computer on for as long as I could.  State #2 seemed to work.  It was functioning.  I lasted a week.  Then McAfee decided to update and decided that I needed to restart.  I acquiesced after being prompted every 15 minutes for 2 days.  Why does McAfee to that?  Don't they know that just makes them annoying?  How about a button guys: Don't remind me ever again!  I shut down, unplugged everything but the keyboard and restarted.  The system froze!  Uh oh!  I unplugged the keyboard and restarted.  The system still froze about 1/3 through POST with *nothing* plugged in but  the monitor.  At this point I hate it and hate DELL.  I own a doorstop.

16.  Bought a Hewlett Packard m9600.  Nuff said.

I just want to thank everyone who offered ideas here and the great support of the DELL tech team.  Really made me feel warm and fuzzy.  Luv ya all and thank you.  For nothing.

0 Kudos