1 Copper

DVD errors on Dell XPS 8100 running Ubuntu Linux 10.04

I bought a Dell XPS 8100 desktop a couple of weeks ago. It has a problem with reading DVDs. I've tried swapping the DVD-+RW drive with which the 8100 was supplied for one from another system which I know works. But I still get errors reading > 80% of discs. So, for example even with the replacement drive, the K3B burning software fails with the following message:



HL-DT-ST DVDRAM GSA-H60N CV02 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump] [%7]




reading sectors 0 to 4108865 with sector size 2048. Length: 4108866 sectors, 8414957568 bytes.

using buffer size of 128 blocks.

Problem while reading. Retrying from sector 78496.

Read error in sector 78496.

Read a total of 78496 sectors (160759808 bytes)





K3b Version: 1.91.0

KDE Version: 4.4.2 (KDE 4.4.2)

QT Version: 4.6.2

Kernel: 2.6.32-24-generic-pae


The same disc which just failed reads fine on my laptop which is running identical software (Linux, K3B...) to the Dell system.

For what it's worth, the details of the operating system are:


Linux scally 2.6.32-24-generic-pae #39-Ubuntu SMP Wed Jul 28 07:39:26 UTC 2010 i686 GNU/Linux


I've tried re-installing everything (including reinstalling the OS from scratch), but it hasn't solved the problem. I suspect therefore that the problem is either a hardware issue other than in the drive itself OR might be some BIOS or other setting which I need to make or some patch of firmware for the drive or some such.

Can anybody shed any light on this, as it's rendering an otherwise great computer system fundamentally unusable, particularly if I can't reliably back it up to DVD.





0 Kudos