Bmore_Jon
1 Copper

Disable Speaker Optiplex 9020

Hello, we installed Windows 7 Professional on our Optiplex 9020s. Whenever a user inputs a headphone, into the front Headphone jack, the audio works fine (it will only play from the headphones and not the internal speaker - as it should). When we unplug the headphones from the jack, the internal speaker plays the audio then. Is there a way to permanently disable the internal speaker without cutting/disconnect it from the Motherboard?

I've tried the following:

Disabling the device (found in Control Panel > Sound) - This also makes the headphone input disabled.

I've tried

  • Open Device Manager
  • In Device Manager click View and click "Show hidden devices"
  • This should make "Non-Plug and Play Drivers" visible in Device Manager.
  • Expand Non-Plug and Play Drivers by clicking the plus and double-click Beep.
  • Within the "Beep properties" window click the Driver tab.
  • Under the driver tab if you wish to temporarily disable this device click the Stop button. If you wish to permanently disable this device under the Startup Type select Disabled.


Any other suggestions would be helpful. Thanks in advance

0 Kudos