kimi-jaine
Bronze

Inspiron 1525 Problems

I purchased a Dell Inspiron 1525 in April 2008.

About 1 month ago I noticed that my computer would automatically shut down when the power cord was removed, I hovered over the battery icon in the bottom right corner and it said 0% available plugged in, not charging.

I Googled the phrase plugged in, not charging and realised lots of people were having the same problem.

I have tried

  • restarting and shutting down my computer (with and without battery and with and without power cord)
  • removing and replacing my battery (while laptop is on and off)
  • a replacement battery from Dell
  • my sister's battery and power cord (she also has a 1525)in my laptop and get the message plugged in, not charging. My battery in her laptop will charge but my power cord in her laptop says plugged in, not charging
  • removing the battery with the laptop on then restarting the laptop and replacing the battery
  • uninstalling and reinstalling the Power Management Software
  • switching between power plans
  • flashing with current bios

All 3 batteries (hers, my original and my replacement) have adequate charge (50% or higher)

I run with Windows Vista Home Basic edition

I had a phone call from the Dell Online Technician. 

He said to;

·        Shut Down the laptop.

·        Press the power button then tap the F2 key until a blue screen appears.

·        On the left sided menu arrow down to Battery Info.

·        On the right side of the screen my computer showed

·         Battery Status = idol

·         Battery % Charged = 99%

·         AC Adaptor = Unknown Device Installed

He then told me that he'll to post me a new ac adaptor.

I did the F2 thing on my sisters computer, hers said

  • Battery Status = idol
  • Battery % Charged = 99%
  • AC Adaptor = 60 w

 Then I did it again on mine with her power cord and mine said

  • Battery Status = idol
  • Battery % Charged = 99%
  • AC Adaptor = Unknown Device Installed

I got my new AC Adaptor and tried the F2, again no luck, still reads as an unknown device.

When I connected the new  AC adaptor I noticed that the battery light flashes 4 times amber/orange/red and one time blue (prior to my new AC adaptor I had no battery light)

The manual says the computer and/or battery is to hot to charge if the battery light flashes amber then blue and to disconnect from the AC power.  I shut down my laptop and removed my battery and my power cord, but I stil get the flashing battery light when I restart.

 

Can someone please help me!

0 Kudos