caddy10
1 Nickel

RE: Intel USB 3.0 eXtensible Host Controller driver for 7720 inspiron 17r special edition

Hi Appu S

System model is Inspiron 17R SE 7720, service tag <Admin Note: removed per privacy policy~RK>, shipping date 4/20/2013, country Australia. OS is Microsoft Windows 8, version 6.2.9200 built 9200, 64 bit. bios version/date Dell inc A15 17May13. Laptop bought on Ebay, sold as New with fault. Fault being that the 4 USB 3.0 ports not working with device manager showing 'Intel(R) USB 3.0 Extensible Host Controller - 0100 (Microsoft)' with a yellow exclamation mark in a triangle. The seller said he had bought it at auction. Tried different usb flash drives in the 4 usb ports but none recognized by the computer. However power is being supplied to the 4 usb ports as a usb led light works in all 4 ports. Updated windows 8 but fault still present. Uninstalled intel(R) usb 3.0 extensible host controller but upon rebooting it was reinstalled. Card reader working ok with SD memory card so can still get info in & out of computer. Tried updating usb drivers from the internet but no luck. Then updated usb drivers from C: drive. intel(r) usb 3.0 extensible host controller-0100(microsoft) with yellow mark in triangle now gone & usb drivers changed to generic drivers. However still no functioning usb ports. Ran full system diagnostic from dell.com.au but no errors found. Downloaded dell backup & recovery program from dell.com.au & created a system recovery DVD DVD restored computer to what i had before & not to factory condition. Prior to creating & restoring system recovery DVD, disk management showed 2 partitions a. system reserved 350MB    b. C: 917.47GB After DVD restored the system i now had 3 partitions a. system reserved 350MB    b. C: 917.47GB    c. recovery 13.70GB So i was surprised that i had to use dell backup & delivery program to install a recovery partition of 13.70GB on the hard drive. I would have thought that dell would already have installed the recovery partition prior to shipping from the factory! Anyway th 4 usb 3 port still not recognizing any usb flash drives. Not sure how to attach device manager but no yellow exclamation marks showing there.

Please advise regards

0 Kudos