Not applicable

Corrupt Bios?

I have a dell laptop and when i press F2 to boot into the bios it looks likes its corrupt. The laptop does boot into windows and displays everything fine and when i press F12 to chose boot priority it displays fine, this problem only happens when I try to boot into the bios.

I tried flashing the bios in windows with a 1545_A14.EXE bios update i downloaded form the dell website, my computer restarted like it said it would but the bios still had the same problem. I created a bootable dos usb stick and tried to update the bios, it looked like it was successfully  but it still has the problem. I disconnected all power and removed the button cell and held the power button in for 10 secs but that didn't work.

Does anyone have anything else I can try or do you think its a faulty motherboard?

All help greatly appreciated!

Tags (2)
0 Kudos

RE: Corrupt Bios?

Hi ethanphillips,

Iā€™d advise that you load defaults in the BIOS and check for issue resolution. Please follow the steps mentioned below to load the BIOS to defaults.

  1. Reboot the computer.
  2. When prompted during POST, press the <F2> key to enter the setup screen.
  3. On the System Setup screen, press the <F9> key.
  4. Press the <Enter> key on Yes to Load Optimized Defaults and restart the computer.

0 Kudos