Explicit.
1 Copper

RE: Notification of update won't go away

1. On you desktop, press WindowsKey-R, this brings up the Run prompt.

2. Type services.msc and hit enter. This brings up the list of services installed on your machine.

3. Look for the Dell ones in the list.

4. Open them, one by one, and in the General tab select the startup type “Disabled”.

5. Hit “OK” to save.

This method seems to work great for me! Although i am currently on a Windows 8 computer, this seems to work the best, as its seems to have permanently disabled the notification. This may work on Windows 10 although I'm not sure. - Explicit. / Zach