Jandaduns
1 Copper

RE: XPS 9550 not working with TB15 Dock

If the root cause of the instable connection to the TB15 is interference with the WiFi, this should be easily 'proven' by disabling WiFi on the laptop. For those of you that still have the TB15, can you confirm the connection to the TB15 is stable with disabled WiFi?

0 Kudos
Gerrit1980
1 Copper

RE: XPS 9550 not working with TB15 Dock

I tried this. Disabling the wifi before docking with the TB15 (also tried after docking). Thought the ethernet might not be disabled/removed when 'in use' due to some power saving feature or something. But no luck. Network disconnected non-the-less.

0 Kudos
erwinrichard
1 Nickel

RE: XPS 9550 not working with TB15 Dock

I noticed (reproducable with 3 boxes) that the network and USB connectivity always drop at the same time, probably the Ethernet is connected internally via USB. Had 2 replacement units for my original ones with exactly the same problem.

IMHO makes no sense to get replacement units until Dell comes out with a new hardware revision.

0 Kudos
jjsalaza
1 Copper

RE: XPS 9550 not working with TB15 Dock

I have also tried this and other alternatives: with and without internet, with and without my 4K monitor, with and without my external keyword, with and without my external mouse, with and without my printer, and some of these combinatorios. It is very painful! No luck! The combination XPS 15 9550 & TB15 is unstable. My TB15 uses a 240W brick by DELL, which should be the right one to connect my XPS 15. I have being finding these troubles since the beginning, and it is very painful and dissapointing!!!

0 Kudos
johnnyblogs
1 Copper

RE: XPS 9550 not working with TB15 Dock

Agreed. I updated all mine and my dock still behaves erratically.

0 Kudos
awi231
1 Nickel

RE: XPS 9550 not working with TB15 Dock

***ATTENTION TO EVERYONE***

After talking to a couple different reps, they're updating the BIOs on all devices using the thunderbolt port and it should fix the issue with the TB15 on the 9550. Supposedly end of JUNE 2016. No promises of course but from what I heard, it looks like it will be the fix. Not sure it is a device issue with the dock like some claim. At least that isn't what Dell is saying on my end. It is a BIOs issue. And they stopped selling because they didn't want anymore backlash. The TB15 will be on the market again once the BIOs update comes out.

0 Kudos
Gerrit1980
1 Copper

RE: XPS 9550 not working with TB15 Dock

New updates are available. Strangely enough, Dell update systemtray application does not see these updates and no mail notification from the Dell site. See http://www.dell.com/support/home/us/en/19/product-support/product/xps-15-9550-laptop/drivers/advance...

I installed them yesterday, no problems so far. When I talked to Dell technical support last month they advised installing updates in a certain order. Normally: BIOS, Drivers, Firmware and Application, but for the TB15 they advised installing the control driver _before_ the firmware. Given that the list of software seems to contain duplicates, my installation sequence:

1. BIOS
Dell XPS 15 9550 A10 System BIOS
XPS_9550_1.2.10.exe
01.02.10 ,01.02.10 Release / Updated: 05 Jul 2016

2. Driver
Intel(R) Thunderbolt(TM) Controller Driver
Chipset_Driver_D91CC_WN32_16.1.47.275_A02.EXE
16.1.47.275 ,A02 Release / Updated: 06 Jul 2016

3. Driver - name double? Other file...
Intel(R) Thunderbolt(TM) Controller Driver
Docks_Stands_Driver_2VCD4_WN32_16.1.47.275_A02.EXE
16.1.47.275 ,A02 Release / updated 08 Jul 2016

4. Firmware - diconnect TB before install
Intel(R) Thunderbolt(TM) 3 Firmware Update
Intel_TBT3_FW_UPDATE_NVM16_A04_2.16.01.003.exe
2.16.01.003 ,A04 Release / updated 08 Jul 2016
    -> there is a duplicate entry; seems to be the same as the release / updated from 06 Jul 2016

5. Firmware - connect TB before install
ASMedia USB 3.0 Extended Host Controller Firmware Utility
USB_Utility_ASMedia_A00_WIN_H43H3_ZPE.exe
1.11.23 ,A00 Release 30 Jun 2016, Updated: 01 Jul 2016

6. Driver
Realtek USB GBE Ethernet Controller Driver
Docks_Stands_Driver_9YCY0_WN64_2.43.2015.1225_A01_02.EXE
Release Date:
 2.43.2015.1225 ,A01 Release 28 Jan 2016, updated: 29 Apr 2016

7. Driver
Intel HD Graphics 530/P530 Driver
Video_Driver_FK4F6_WN32_20.19.15.4454_A06.EXE
20.19.15.4454 ,A06 Release / Updated: 29 Jun 2016

I did not install the audio drivers at this moment, since I do not use those features. Will keep you posted if there are any problems. Hope Dell finally got this problem sorted out and it is not a hardware issue as some people imply.

0 Kudos