Not applicable

Dell XPS 11 processor running at 0.59Ghz


I have a Dell Laptop with an Intel Core i5-4210Y processor. The processor should run at 1.5Ghz with turbo up to 1.9GHz.

For the last month I notice my computer incredible slow, 1080p YouTube videos won’t play smooth in fullscreen for example. Checking my CPU with different utilities I saw that no matter what I’m doing it is always at 0.59Ghz only. Even I tried cinebench and other intensive tasks and nothing. That’s why is running so slow. It checked online and I saw plenty of people with the same problem but no solutions.

What I know:

- It’s not a hardware problem or a limitation of the chipset or BIOS because if I restart in safe mode the processor is running at 1.5Ghz as it supposed to.

- I tried ThrottleStop but it says that my processor speed is 0.59Ghz max and no throttle.

- I read people saying is due the Intel Dynamic Platform & Thermal Framework. In settings power limit and acoustic limit are both at 5 and TDP level is correct. I tried to uninstall and still at 0.59Ghz, and reinstall latest version and nothing.

I’m quite sure formatting and reinstall windows might solve the problem, but if possible I would like to avoid that. Any ideas how could this be fixed?


0 Kudos