Jordan94
1 Copper

Inspiron 7559 - Memory management BSOD after attempting to update BIOS

Hello. I have a Dell Inspiron 7559 and yesterday the Dell Update application notified me of a BIOS update. I didn't think it could be so much of a problem (unfortunately) so I run the update and followed the on screen instruction. I don't know if the update went through or not, but after that whenever I try to boot Windows I am greeted by a "MEMORY MANAGEMENT" BSOD.

I have tried flashing different BIOS versions (every single one found on the Dell support page for my machine) and while the update goes well it doesn't solve the problem. I have also tried to reinstall Windows and I am able to get it to boot if I choose the 32 bit installation but only 1.89GB out of 8GB are usable. If I choose the 64bit installation (the one I had originally) I can't even get to the desktop. Dell Diagnostic tool finds no error and neither Memtest86 (4 passes run, now I am trying with 10). Any idea how I could solve this problem? Thank you in advance

Tags (3)
0 Kudos