ashek1520
1 Copper

dell studio 1555, charger does not seem to work

Hello,

I have dell studio 1555. It was working fine.  For last 6 months I did not use it. Now when I try to connect it with charger, its not charging.  As I have not used it since long, the battery is dead.

When I plug in charger, I see  blue light on the connecting end of charger (at the pin that connects to laptop). However as soon as i connect it to laptop, the blue light goes off, Also there is no sign in the laptop to indicate charging. The laptop is not powering up.

Based on tips given in youtube url 

I think the charger is up. However I dont understand why charger blue light goes off when I connect it to the laptop.

Any suggestion to fix this issue.

Many thanks
Abhishek

0 Kudos
Moderator
Moderator

RE: dell studio 1555, charger does not seem to work

Hi Abhishek,

Iā€™d suggest that you follow the steps mentioned below and check for issue resolution.

  1. Switch off the computer.
  2. Disconnect the AC adapter from the system.
  3. Remove the battery from the computer.
  4. Press and hold down the power button for 15 seconds.
  5. Then connect back all the peripherals and check for issue resolution.

In addition, I would suggest you to update the BIOS on the system. Please enter your service tag # on the link below, select the OS, then download the BIOS from BIOS section onto the system and install it.

http://dell.to/18r60nI

Also, we will have to check the status of the adapter in BIOS; if the adapter is not detected properly the system will continue to receive power but will not charge the battery. Please follow the steps mentioned below to check if the adapter is detected properly.

  1. Start the computer by pressing the power button.
  2. Press the F2 key 2-3 times
    you will now be on the BIOS screen.
  3. Under the Main Tab look for the option that says AC Adapter Type
    If the Adapter Type says Unknown or None with the adapter plugged in.
  4. Reconnect the adapter to the machine and if the status now shows as Unknown then the AC Adapter needs to be replaced.

Also, I would suggest you to run a thorough test on the battery. You can download Support assist from the link below and run the PC CHECKUP on Battery to check for issues

http://dell.to/1hAPOXr

Please let me know the findings.

0 Kudos