rboerner
6 Indium

RE: XPS9560 Bios 1.2.4 bricking systems

Just to add a 'me too', I had seen this post prior to attempting to update the BIOS of my 9560. Waited a bit to see if there were more reports or if Dell pulled the BIOS.

Decided to take a chance today and the same bad behavior happened, in that even though the update completed successfully, when the system tried to restart it hung at the Dell OEM logo. As others have stated, the Caps Lock key was responsive, and shutting down and repeating the process and tapping the F2 or F12 key appeared to indicate the system was going to enter the BIOS setup or one time boot menu respectively, but the blue progress bar stayed on the screen (at 100%) and nothing ever happened.

I eventually booted while holding down the 'Fn' key to force 'Diagnostic Boot Mode' (at least I think that was the message in yellow text in the upper right-hand corner of the screen) and then the system booted into Windows. Subsequent attempts to warn and cold boot have worked as expected.

0 Kudos