wahwah80
1 Copper

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

In my case deactivating the legacy ROM option has solved the delay during POST and allowed me to boot!

I did the following:

1. msconfig in windows 10. Set safe boot option. This is necessary as windows won't boot normally once AHCI set.

2. reboot and enter bios (F12)

3. uncheck legacy ROM option and switch from RAID to AHCI

4. let windows 10 boot in safe mode

5. run msconfig and uncheck the safe boot option

6. Reboot into Windows (should work now)

7. Reboot and install Linux from USB media