Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi,

I have Dell Inspiron N4050 laptop and from 3 months or 6, the battery would not charge but tells me 

"0% available (Plugged in, Charging)" but not charging. I took the battery out and opened it and everything was fine!

Please help me because i need the laptop battery working because i use the laptop for work and i need it

Thanks!

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi HassanWael,

Thank you for reaching out to Dell Community Forum.

Please boot into BIOS <F2> and check the status of the battery and adapter listed there.

Please click my DELL-username and send me a Private Message with the Dell Service Tag number and your email address.

Note: please don't mention the service tag or email id on the public forum as it contains your personal information

DELL-Akshatha M
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi DELL-Akshatha M,

In the BIOS <F2> it would not show me the battery status but i see the adapter type : 65W

Thanks!

0 Kudos
8 Krypton

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Is this the factory original system battery?  If so, it's long past its expected lifespan and likely needs to be replaced.

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi ejn63,

Yes, but its not dead because i opened the battery and every lithuim battery was ok!

Thanks!

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi,

Anybody have an idea that might fix my problem please tell me .

Thanks!

0 Kudos
8 Krypton

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Replace the battery.  It's not clear how you determined the battery is OK, but there's a lot more to the operation of a battery pack than the condition of the cells -- and this battery is about six years old - or well beyond twice its expected lifespan.

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi ejn63,

I am sorry, but i forget to mention something important and i am going to tell it to you now,

From 3 or 6 Months i was going to clean the laptop so i got my spray and shut down the computer while the battery was inside the computer, while the computer was shutting down and the battery inside i got my spray and throw on the laptop keyboard because some of the keys was not working, then i listened that the hard drive like stopped and the computer shut down as if i was clicking on the power button and the laptop did not turn on for 1 week but while it was not turning on, when i put the AC adapter it would show the battery is charging, when i tried turning on the laptop and it run perfectly the battery was Ok and i kept using the battery and after some days the battery was on 15% and it needed to be charged and i plugged in the AC adapter and it was not charging.

Let me tell you about the keyboard problem also,

While i was working on the laptop suddenly some of the laptop keys was not working i disassembly the laptop and re plug the cable again and the problem was still not fixed so i took the cable off and put the keyboard and everything and what i was telling up is what happened and the cable till now is disconnected.

Might be because the keyboard cable is unplugged? Or what?

Please tell me because i think this will help you alot

Thanks!

0 Kudos

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

Hi,

Sorry if i am sending it again but i need a fast answer because i need the laptop for work

Thanks!

0 Kudos
8 Krypton

RE: Dell Inspiron N4050 Battery says "0% available (Plugged in, Charging)" but not charging

That changes the diagnosis appreciably.  Since you used a liquid - most likely conductive - on a system that was powered up (with the battery in, the system is live at all times), you likely shorted out the charging system - you may have just a bad battery (due to age; this system is somewhere around four or five years old), but it's probable the mainboard is bad as well.

Since both together will be 50% or more of the cost of a replacement system, your best course of action is to retire the system and replace it.

0 Kudos