1 Copper

Dell Inspiration 7353 BIOS Update bring legacy boot failed Windows 8.1


I really appreciate the good design of Dell Inspiration 7353 laptop, it's good, mostly indeed.

Recently I have a problem to use legacy boot (USB, DVD/CD, Internal HD, whatever), after I have upgraded the BIOS to the latest one (Inspiron_3153_3158_7353_7359_7568_1.13.0). Due to legacy boot is required in my daily work, so I will ask for help, see if anyone can give me a solution.

When I used the laptop without any BIOS upgrade, it can boot from any legacy driver (USB, etc) with Windows 7, 8+ etc. 

Then it had a small USB issue, I thought I should try to upgrade BIOS, see if this can help, then soon I started to regret, because I had found that all legacy boot is failed, the Windows 8.1 throw me into a BSOD, tell me PAGE FAULT error. I have tried USB, internal HD & DVD, all same.

Then I googled, saw someone had similar problem (not same), he cleared CMOS by pull out the battery, so I tried it without any hope, but surprisingly, when I pull out the battery and remove the connection of power adapter and laptop battery, by pressing the power button several time with & without power cord connected, then I installed the CMOS battery, laptop battery, restart the laptop.

When I press F12 to load the boot menu, it really can load legacy bootable device, but that's one time thing. After the system reboot, the problem back again, looks like if I want to boot into legacy bootable device, I will have to remove CMOS battery each time like above all...sad.

I thought BIOS can support legacy bootable device before I have upgrade it, so the BIOS update file might be the problem, so I tried all BIOS version, indeed, all of them except the latest version, no one really worked, I tried change different option in BIOS for more than ten times probably, not working at all.

So I am here to see if any dell professional IT techie, could check the BIOS or test the BIOS update once more, and tell me how to resolve this issue, or maybe send me a downloadable default 7353 BIOS (not any update in the driver & download page), so I can restore it to the original one, then I can get to work soon, that will be grateful, and a million time thanks.

A suggestion, maybe providing a default BIOS update (factory original one) in the driver & download page, could be a great help for customers like me.

Best regards,


Tags (2)
0 Kudos