9 Rhodium

RE: Dell inspiron 7520 bios problem

Click on "Intel Rapid start" as highlighted and turn it OFF.  Then you can access the SATA setting (it should then in fact revert to AHCI without further action).

0 Kudos