oOJackOo
1 Copper

Inspiron 11-3168 BIOS bug?

I currently have the latest bios (2.1.1) installed and noticed there's no longer ANY way to boot Legacy ROM USB drives. When it used to work just fine, now not only do USB drives not show up in list under Legacy in F12 boot menu, but selecting to boot USB Drive shows "No Operating System Found".

Now here's the trick if I simply wait with the boot menu on screen for around 5-10 minutes then select USB Drive to boot, it boots up my live Linux distro just fine, it not always works it's hit and miss, and not all live Linux distros work, but obviously the BIOS is capable of booting it so why does this BIOS on the Inspiron 11-3168 work like this?

I tried downgrading to BIOS version 1.0.7 nothing changed, then 1.0.6 still nothing so came back up to version 2.1.1. When I first got this laptop I clearly remember booting Legacy Drives a lot and the worked perfectly and showed up in the list on the boot menu since then I updated the BIOS twice from 1.0.7 to 2.0.3 then again to 2.1.1. So one of those updates must have broken something with booting Legacy ROM drives.

0 Kudos