mdwpsyd
1 Nickel

Windows 10 - WiFi does not work

This seems to be a problem affecting a lot of people based on my last 11+ hours of trying to fix it and seeing so many posts on the Microsoft support site, some here on Dell, and elsewhere on the interwebs.

Ever since I updated to Windows 10 (I have the 'Pro' version, although I doubt that makes a difference), I have not been able to connect to the Internet via WiFi. I am using my iPhone to connect at the moment. I am hoping you all might be able to help. 

I have a Dell desktop, although this problem seems to affect laptops too. Here's my system:

Dell XPS 8700
Processor: Intel Core i7-4790 CPU @ 3.60 GHz
Installed memory (RAM): 8.00GB
System type: 64-bit Operating System, x64-based processor

Windows Internet Connection Troubleshooter

I have run the trouble shooter (Right-click on WiFi icon in system tray) at least 20 times, but no luck. 

RedmondPie.com

A post on RedmondPie.com seems to have the most knowledgeable suggestions, although unfortunately none have worked for me, but they might for others. I am also mentioning it so that you know I tried the main suggestion in the post, which is also on the Microsoft website (deleting a VPN something-or-other from the Registry), and many of the suggestions in the comments:

www.redmondpie.com/fix-no-wi-fi-available-after-windows-10-upgrade-issue-heres-how

Revert to Previous Network Adapter Driver

One of the suggestions, which seemed to help a lot of people, is to revert back to the previous network adapter driver. I tried it, but it did not work. Here is my installed driver, and the previous one, which I installed using the "Roll Back" function (Device Manager > Network adapters > Dell Wireless 1704 802.11b/g/n > Properties > Driver > Roll Back Driver):

INSTALLED DRIVER:
Dell Wireless 1704 802.11b/g/n (2.4 GHz)
Driver Provider: Broadcom
Driver Date: 7/30/2015
Driver Version: 7.35.295.0
Digital Signer: Microsoft Windows Hardware Compatibility Publisher

ROLLED BACK DRIVER:
Driver Provider: Broadcom
Driver Date: 6/2/2013
Driver Version: 6.30.223.256
Digital Signer: Microsoft Windows

I went back to the current driver (Version: 7.35.295.0) and tried Update Driver, but that did not work.

Dell SupportAssist

I used Dell SupportAssist - checked my system, and it did find the problem - no wireless connection. Interestingly, it said the signal strength from my router is "very strong", but it was not able to fix the underlying problem. This result made sense because I am able to connect to my wireless via my iPhone 6 and my Chromebook.

Windows 10 Updates

I have run all Windows 10 Updates. 

Dell Technical Updates

I subscribed to Dell Technical Updates, and installed two Recommended updates related to the network adapter:

BCM_Wireless_WT4_D3P4M_A01_Setup_ZPE

Windows 10, 64-bit

Driver and description: This package provides Dell DW1704 802.11 b/g/n Driver and is supported on XPS 8700 running the following Windows Operating systems: Windows 10.
Download URL: www.dell.com/.../DriversDetails;fileid=3479174503
Criticality:Recommended
Release date:8/13/2015 7:54:10 AM

8700_Network_Driver_HV7H1_WN32_18.11.0_A00

Driver and description: This package provides Intel 7260 WiFi Driver and is supported on XPS 8700 running the following Windows Operating systems: Windows 10.

Download URL: www.dell.com/.../DriversDetails;fileid=3475171474
Criticality:Recommended
Release date:7/29/2015 3:10:01 AM

I had great hopes that these installations would fix the problem, but alas, my hopes were dashed. 

Reboots

I rebooted after each fix attempt.

Internet Service Provider

I called my ISP (Charter). I reached someone right away, and she was very polite and professional. She confirmed that my router was working fine. She said a good number of customers have had this problem after installing Windows 10, but that unfortunately it was not something they could solve since it is a Microsoft problem. Although she recommended contacting Dell (after ascertaining that I had a Dell PC), and even had the Dell support number for me. (It was after hours, so I'll have to wait until business hours to call Dell, but I'll wait to see if I receive any replies here first.)

Microsoft Support

I called the Microsoft support line, after spending 2-3 hours on their support forum, waited on hold for 52 minutes, and then was disconnected. I called back and received a recording saying they were not open. 

System Restore & Reset

I tried a system restore, but that (predictably) did not work, since the problem is with Windows 10. 

I tried a system reset--losing all the programs, er, I mean 'apps', I had installed over the past month since I but the XPS 8700--but it did not help.

Any Suggestions?

Please let me know if you have any suggestions to fix this vexing problem.

Thank you very much,

Mark