1 Nickel

No boot device available error Inspiron 530 Windows 7


My computer worked fine. I recently tried to format and re-install windows 10 64 (Bit) onto my HDD and catastrophic failure occurred. Here's what I did:

I flashed a USB using Rufus and installed the ISO as a GPT Partition Scheme for UEFI with a Large FAT32 File system. I could not get the Inspiron to boot to my USB so I put the HDD in a bench and formatted it accordingly. Once windows 10 installed properly and was on the desktop, I popped it back into the Dell, and now I get the Error "No Boot Device Avilable" I theorize it has something to do with the way I installed windows?

Things I've tried:

Putting the HDD in every Sata slot

Checked the boot order, HDD is number one.

Disabled Floppy Disk

Uninstalled every other SATA component

Changed the drive from IDE to RAID and back

The drive works fine, because it boots in the bench. The Sata cable works fine, but for some reason this computer doesn't register it as a bootable device.



Anyone have any ideas? Is it because it's windows 10? Is it because its 64 bit? Is it because I installed windows on a test bench? I'm out of ideas here boys. Help me out!

Labels (2)
Tags (1)
0 Kudos