ThePCMac
1 Copper

RE: Precision 7510 Win 7 Reinstall

I was having the exact same issue and you and after days of searching the interweebs and hours on the dell support line, they were not able to help me.

I ended up finding a extremely convoluted way of getting it to work. I'll spare you all the failed attempts because it's just too many to name and IDK WHY this has to be so freaking hard.

1st. You will need to go and download the Samsung controllers not the Intel or any other ones as they don't allow the OS to write to the disk. DISKPart  converting to MBR or GPT does not work either because the driver is not correct. I used and I can't remember what form I got it off of but the name is Samsung NVMe Driver V1.4.7.17 WHQL for Win7 think this is it www.win-raid.com/t29f25-Recommended-AHCI-RAID-and-NVMe-Drivers.html . Extract the files to your usb in a folder called Samsung or whatever you want to call it

2nd. Remove the raid setting in the BIOS and set it to ACHI. That's it for the bios for now, but we'll be back soon

3rd. Your usb must have the USB 3 drivers injected into the ISO see https://downloadcenter.intel.com/download/25476/Windows-7-USB-3-0-Creator-Utility

4th. Boot from your USB and once you get past the agreement and go to install the OS, you will need to install the Samsung driver in order to see the Drive. Once you see the drive, just click next to stat the install process.

5th. Because we changed the Raid setting, once the install process reboots the machine, you will get a boot device not found. Just reboot the machine and hit F12 to boot back to the internal drive. The process will then continue. Final reboot after installation is successful. Once again F12 and boot back to internal drive once you get the boot device not found again.

6th. Because this is probably a bare bone installation of windows, you will have no drivers such as usb and network drivers etc. I was able to get around this by booting windows as if I was trying to reinstall windows again and going through the process of loading up the Samsung driver to recognize the internal disk. Once it saw the disk, I backed all the way out of the install process to get to the repair option and then selected install drivers. Loaded all the 7510 drivers from a folder I had on my usb onto the primary drive to the desktop. Rebooted and we back to windows and installed the usb3 drivers and wireless drivers.

7th. After all that, I restarted the computer and went back into the BIOS and changed switched from UEFI to Legacy so that I didn't have to keep hitting F12 and select the internal drive.

I hope this helps someone else because this was a real B@#$ to figure out.