Neal Miller
2 Iron

Power settings resetting and removing passwords

Relevant specs:
Dell XPS 8930
GeForce GTX 1080
Windows 10

I'm having two problems with my new Dell XPS 8930, and I suspect they're related.

First, the power settings keep reverting to "Power saver." I repeatedly set it on "High Performance," but it frequently switches back for no clear reason. Another thread suggesting that it switches automatically when the GPU (NVIDIA GeForce GTX 1080) is running too hot, but I don't think this is the case, given the switch often happens in the middle of the night when no applications are in use. CPU idle is 41C, GPU idle is 55C.

Normally, I wouldn't care too much about the "Power Saver" setting, except that the setting allows the system to go to sleep, which prohibits me from remotely accessing the desktop from TeamViewer. My goal in this case is to ensure that my system never, ever goes to sleep under any circumstances, so I can remote-access it at any time.


In addition, some mornings when I bring the desktop out of sleep mode, it demands a password. A month ago, I followed the instructions here to disable the password screen:

... The checkbox remains unchecked, and it should not be asking for a password. Regardless, I'm forced to enter it when the system comes out of sleep mode, which it shouldn't be entering in the first place. My goal is to disable the password requirement completely. It's possible that if the Power Settings issue is fixed, then the sleep mode problem will never manifest.

Many thanks for any help.