thewatchman
Copper

P2715Q monitor, won't wake from sleep from power saving

P2715Q monitor, won't wake from sleep (from power saving mode apparently):

I am running Linux with 4.10.0-27-generic kernel. Using Xsreensaver. After the monitor goes to sleep, standby, or suspend for a while when I try to log back in it will not wake up. Using "xrandr --output DP-2 --left-of DVI-D-0 --auto" once or twice brings it back from a sleep state. My other monitor works fine so this is obviously something related to the Dell P2715Q monitor. I had been hoping for a while that a kernel update or Nvidia update would fix this problem but not such luck. After multiple updates nothing has fixed this issue.

I have tried different window managers and screen savers and the monitor exhibits the problem in all cases so far.

My guess at this point is that the monitor goes into a deep sleep state after being set to standby (or suspend or sleep) for a while and does not respond to normal wake up commands. I am suspecting Dell requires a non-standard commands to wake it. I noticed the monitor firmware does not appear to allow disabling the deep sleep state on this monitor (as a work around) for some reason. Other Dell monitors allow this work around.

I noticed several old posts about this issue. One person posted that resetting the energy star settings solved their problem. This is hard to believe since the only energy star setting is the LED state. In any event this did nothing to fix my monitor.

This appears to be a serious flaw with the monitor. Is there a firmware update to resolve this? If the means cannot be provided to me to update the firmware or otherwise fix this issue will Dell send me a postage paid box so that the monitor can be sent back to them for an update. Alternatively can they provide a solution to this: driver code or pseudo code that will allow the monitor to function correctly or allow the monitor to be made to function correctly? Also, I did not see any technical responses from Dell for the other posts about this question. I hope I am able to get a solution to this soon.

I have done a bit more troubleshooting. I have tried different cables the DP, the mDP, and an HDMI. What I found is that the HDMI does not have the wake from sleep issue, but the display port cables do. I saw a post on amazon indicating this was an issue with the firmware for the display port that needs to be updated and this is consistent with what I am seeing. Does anyone know the manufacturer of the display port portion and have technical information on how to get the firmware and flash it? I hope dell can help with this.

0 Kudos