ennss
1 Nickel

UP2414Q won't reliably resume from sleep or reboot using mDP to DP cable

Monitor = UP2414Q
Video card = Sapphire R9 270
Cable = Dell mDP to DP
Computer = i5 CPU,  32GB
Operating System = Windows 7 64bit (latest drivers, bios etc.)
Display set to 3840x2160 - DP 1.2
No other monitors, video cards or associated drivers are installed.

Monitor is brand new. I have 30 years of experience, building, programming, administering a huge variety of PC systems.  I know the difference between hardware, BIOS, firmware, drivers. etc. About half the time, the monitor will not properly resume from the computer being asleep, or from a warm or cold reboot of the system, i.e.  The monitor will need to be powered off and powered back on for the display to resume, and/or the display will resume in an incorrect resolution and the AMD video card drivers will display one of the following messages:
1)   "The system as detected a problem with the connection between your computer and the displayport display the will prevent you from using the highest resolutions and/or refresh rates..."
or
2) "The system has detected and link failure and cannot set the requested resolution on your displayport display..."

Since the display will often be blank during reboot (no BIOS messages displayed, monitor power-off/power-on required), before windows has started, it does not have anything to do with Windows, drivers or any other software. This points to a hardware and/or firmware/video card bios issue between the video card and monitor. Correct DP 1.2 communication is not occuring consistently.

I am waiting for the arrival of a new accell displayport 1.2 cable that I've ordered to see if that helps.

Please advise what video cards have been tested with this monitor to work correctly using 3840x2160 60hz, DP 1.2.

Please advise if there is a monitor firmware update available to address this issue.

Please advise what other steps I can take to resolve the issue.

0 Kudos