Petrochem
1 Nickel

Dell S3048-ON Switch Trunk ports with DHCP

Capture.PNGHello, hope you can help me. we are having trouble installing our aruba with the setup in the picture my guess is its not acquiring a valid IP address. below is the config of the switch. hope you can guide me how to get this working.

 

 

show run
Current Configuration ...
! Version 9.11(2.1)
! Last configuration change at Tue Jul 17 16:43:25 2018 by default
!
hostname Dell
!
protocol lldp
!
redundancy auto-synchronize full
!
default vlan-id 69
!
stack-unit 1 provision S3048-ON
!
interface GigabitEthernet 1/1
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/3
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/4
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/5
no ip address
shutdown
!
interface GigabitEthernet 1/6
no ip address
shutdown
!
interface GigabitEthernet 1/7
no ip address
shutdown
!
interface GigabitEthernet 1/8
no ip address
shutdown
!
interface GigabitEthernet 1/9
no ip address
shutdown
!
interface GigabitEthernet 1/10
no ip address
shutdown
!
interface GigabitEthernet 1/11
no ip address
shutdown
!
interface GigabitEthernet 1/12
no ip address
shutdown
!
interface GigabitEthernet 1/13
no ip address
shutdown
!
interface GigabitEthernet 1/14
no ip address
shutdown
!
interface GigabitEthernet 1/15
no ip address
shutdown
!
interface GigabitEthernet 1/16
no ip address
shutdown
!
interface GigabitEthernet 1/17
no ip address
shutdown
!
interface GigabitEthernet 1/18
no ip address
shutdown
!
interface GigabitEthernet 1/19
no ip address
shutdown
!
interface GigabitEthernet 1/20
no ip address
shutdown
!
interface GigabitEthernet 1/21
no ip address
shutdown
!
interface GigabitEthernet 1/22
no ip address
shutdown
!
interface GigabitEthernet 1/23
no ip address
shutdown
!
interface GigabitEthernet 1/24
no ip address
shutdown
!
interface GigabitEthernet 1/25
no ip address
shutdown
!
interface GigabitEthernet 1/26
no ip address
shutdown
!
interface GigabitEthernet 1/27
no ip address
shutdown
!
interface GigabitEthernet 1/28
no ip address
shutdown
!
interface GigabitEthernet 1/29
no ip address
shutdown
!
interface GigabitEthernet 1/30
no ip address
shutdown
!
interface GigabitEthernet 1/31
no ip address
shutdown
!
interface GigabitEthernet 1/32
no ip address
shutdown
!
interface GigabitEthernet 1/33
no ip address
shutdown
!
interface GigabitEthernet 1/34
no ip address
shutdown
!
interface GigabitEthernet 1/35
no ip address
shutdown
!
interface GigabitEthernet 1/36
no ip address
shutdown
!
interface GigabitEthernet 1/37
no ip address
shutdown
!
interface GigabitEthernet 1/38
no ip address
shutdown
!
interface GigabitEthernet 1/39
no ip address
shutdown
!
interface GigabitEthernet 1/40
no ip address
shutdown
!
interface GigabitEthernet 1/41
no ip address
shutdown
!
interface GigabitEthernet 1/42
no ip address
shutdown
!
interface GigabitEthernet 1/43
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/44
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/45
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/46
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/47
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/48
no ip address
portmode hybrid
switchport
no shutdown
!
interface TenGigabitEthernet 1/49
no ip address
shutdown
!
interface TenGigabitEthernet 1/50
no ip address
shutdown
!
interface TenGigabitEthernet 1/51
no ip address
shutdown
!
interface TenGigabitEthernet 1/52
no ip address
shutdown
!
interface ManagementEthernet 1/1
no ip address
no shutdown
!
interface ManagementEthernet 2/1
no shutdown
!
interface ManagementEthernet 3/1
no shutdown
!
interface ManagementEthernet 4/1
no shutdown
!
interface ManagementEthernet 5/1
no shutdown
!
interface ManagementEthernet 6/1
no shutdown
!
interface Vlan 1
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
ip helper-address 10.37.3.1
shutdown
!
interface Vlan 2
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 15
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
untagged GigabitEthernet 1/3
shutdown
!
interface Vlan 30
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 31
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 69
!
interface Vlan 90
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 100
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 998
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 999
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 1001
name PLDT-UPLINK-VLAN
no ip address
untagged GigabitEthernet 1/43-1/45
shutdown
!
interface Vlan 1002
name GLOBE-UPLINK-VLAN
no ip address
untagged GigabitEthernet 1/46-1/48
shutdown
!
line console 0
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!
reload-type
boot-type normal-reload
config-scr-download enable
!
end

0 Kudos
Petrochem
1 Nickel

Dell S3048-ON Switch Trunk ports with DHCP

Capture.PNGHello, hope you can help me. we are having trouble installing our aruba with the setup in the picture my guess is its not acquiring a valid IP address. below is the config of the switch. hope you can guide me how to get this working.

 

 

show run
Current Configuration ...
! Version 9.11(2.1)
! Last configuration change at Tue Jul 17 16:43:25 2018 by default
!
hostname Dell
!
protocol lldp
!
redundancy auto-synchronize full
!
default vlan-id 69
!
stack-unit 1 provision S3048-ON
!
interface GigabitEthernet 1/1
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/2
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/3
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/4
no ip address
switchport
no shutdown
!
interface GigabitEthernet 1/5
no ip address
shutdown
!
interface GigabitEthernet 1/6
no ip address
shutdown
!
interface GigabitEthernet 1/7
no ip address
shutdown
!
interface GigabitEthernet 1/8
no ip address
shutdown
!
interface GigabitEthernet 1/9
no ip address
shutdown
!
interface GigabitEthernet 1/10
no ip address
shutdown
!
interface GigabitEthernet 1/11
no ip address
shutdown
!
interface GigabitEthernet 1/12
no ip address
shutdown
!
interface GigabitEthernet 1/13
no ip address
shutdown
!
interface GigabitEthernet 1/14
no ip address
shutdown
!
interface GigabitEthernet 1/15
no ip address
shutdown
!
interface GigabitEthernet 1/16
no ip address
shutdown
!
interface GigabitEthernet 1/17
no ip address
shutdown
!
interface GigabitEthernet 1/18
no ip address
shutdown
!
interface GigabitEthernet 1/19
no ip address
shutdown
!
interface GigabitEthernet 1/20
no ip address
shutdown
!
interface GigabitEthernet 1/21
no ip address
shutdown
!
interface GigabitEthernet 1/22
no ip address
shutdown
!
interface GigabitEthernet 1/23
no ip address
shutdown
!
interface GigabitEthernet 1/24
no ip address
shutdown
!
interface GigabitEthernet 1/25
no ip address
shutdown
!
interface GigabitEthernet 1/26
no ip address
shutdown
!
interface GigabitEthernet 1/27
no ip address
shutdown
!
interface GigabitEthernet 1/28
no ip address
shutdown
!
interface GigabitEthernet 1/29
no ip address
shutdown
!
interface GigabitEthernet 1/30
no ip address
shutdown
!
interface GigabitEthernet 1/31
no ip address
shutdown
!
interface GigabitEthernet 1/32
no ip address
shutdown
!
interface GigabitEthernet 1/33
no ip address
shutdown
!
interface GigabitEthernet 1/34
no ip address
shutdown
!
interface GigabitEthernet 1/35
no ip address
shutdown
!
interface GigabitEthernet 1/36
no ip address
shutdown
!
interface GigabitEthernet 1/37
no ip address
shutdown
!
interface GigabitEthernet 1/38
no ip address
shutdown
!
interface GigabitEthernet 1/39
no ip address
shutdown
!
interface GigabitEthernet 1/40
no ip address
shutdown
!
interface GigabitEthernet 1/41
no ip address
shutdown
!
interface GigabitEthernet 1/42
no ip address
shutdown
!
interface GigabitEthernet 1/43
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/44
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/45
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/46
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/47
no ip address
portmode hybrid
switchport
no shutdown
!
interface GigabitEthernet 1/48
no ip address
portmode hybrid
switchport
no shutdown
!
interface TenGigabitEthernet 1/49
no ip address
shutdown
!
interface TenGigabitEthernet 1/50
no ip address
shutdown
!
interface TenGigabitEthernet 1/51
no ip address
shutdown
!
interface TenGigabitEthernet 1/52
no ip address
shutdown
!
interface ManagementEthernet 1/1
no ip address
no shutdown
!
interface ManagementEthernet 2/1
no shutdown
!
interface ManagementEthernet 3/1
no shutdown
!
interface ManagementEthernet 4/1
no shutdown
!
interface ManagementEthernet 5/1
no shutdown
!
interface ManagementEthernet 6/1
no shutdown
!
interface Vlan 1
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
ip helper-address 10.37.3.1
shutdown
!
interface Vlan 2
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 15
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
untagged GigabitEthernet 1/3
shutdown
!
interface Vlan 30
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 31
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 69
!
interface Vlan 90
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 100
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 998
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 999
no ip address
tagged GigabitEthernet 1/1-1/2,1/4
shutdown
!
interface Vlan 1001
name PLDT-UPLINK-VLAN
no ip address
untagged GigabitEthernet 1/43-1/45
shutdown
!
interface Vlan 1002
name GLOBE-UPLINK-VLAN
no ip address
untagged GigabitEthernet 1/46-1/48
shutdown
!
line console 0
line vty 0
line vty 1
line vty 2
line vty 3
line vty 4
line vty 5
line vty 6
line vty 7
line vty 8
line vty 9
!
reload-type
boot-type normal-reload
config-scr-download enable
!
end

Tags (1)
0 Kudos
Moderator
Moderator

Re: Dell S3048-ON Switch Trunk ports with DHCP

Just to confirm, is it the Aruba AP that does not have an IP Address? Or is the clients connecting to the AP that are not getting an IP Address? If the wifi client has a static IP, is it able to ping the DHCP server?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Petrochem
1 Nickel

Re: Dell S3048-ON Switch Trunk ports with DHCP

Hi Daniel,

Thank you for looking in this. to answer your question, the AP itself is not getting any IP. We allowed 10 VLANs to the trunk port and we also tried connecting a laptop just to isolate the issue but the laptop too is not getting any IP.

0 Kudos
Moderator
Moderator

Re: Dell S3048-ON Switch Trunk ports with DHCP

I suggest connecting to this interface with a client that has a static IP. Then try pinging the DHCP server from this client. This will help ensure that the pathway to the DHCP server is unimpeded.

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Petrochem
1 Nickel

Re: Dell S3048-ON Switch Trunk ports with DHCP

Hi Daniel,

I connected a laptop into interface GigabitEthernet 1/3 which is an access port and it can acquire an IP from vlan 15 but upon connecting it to interface GigabitEthernet 1/2 which is a trunk port its not acquiring any IP. I also tried giving it a static IP from VLAN 15 (the IP dynamically acquired from Gig1/3) but unable to ping its gateway. What do you think could be wrong here? 

0 Kudos
Moderator
Moderator

Re: Dell S3048-ON Switch Trunk ports with DHCP

The reason the laptop did not acquire an IP on VLAN 15 when plugged into port 1/2, is because the laptop is not sending tagged packets for VLAN 15. Is the AP configured to tag VLAN 15?

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos
Petrochem
1 Nickel

Re: Dell S3048-ON Switch Trunk ports with DHCP

Found the issue.

Dell(conf)#interface range gig1/1, gig1/7

Dell(conf-if-range-gi-1/1,gi-1/7)#show config

!

interface GigabitEthernet 1/1

no ip address

portmode hybrid

switchport vlan-stack trunk

no shutdown

!

interface GigabitEthernet 1/7

no ip address

portmode hybrid

switchport vlan-stack trunk

no shutdown

 

where gig1/1 is my uplink to my distribution switch and gig1/7 is my port to access point.

 

Dell(conf)#show vlan

NUM Status Description Q Ports
* 1 Active U Gi 1/1,1/6-1/7

 

Thank you sir Daniel

0 Kudos
Moderator
Moderator

Re: Dell S3048-ON Switch Trunk ports with DHCP

Glad to hear you got this working! Thanks for posting up the config that worked for you.

Cheers

Daniel Covey
Dell EMC| Enterprise Support Services
Get support on Twitter:@DellCaresPRO
Download our QRL app:iOS, Android, Windows
Dell Networking Resources

0 Kudos