avengerispp
1 Nickel

如何在R730xd上锁定CPU主频?

最近需要在R730xd上锁定CPU主频(为了做研究),但遇到一些困难,现在的设置是这样的:

1)用的操作系统和内核版本是Ubuntu 16.04 and 4.15.0-33-generic.

2)禁用了intel_pstate 驱动 (Add "intel_pstate=disable" to /etc/default/grub)

   现在运行 cat /sys/deices/system/cpu/cpu*/cpufreq/scaling_driver 会显示sacpi-cpufreq

2) 用了userspace governor (sudo cpupower frequency-set -g userspace)

   现在运行 cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor 会显示 userspace

3) 设置了指定的频率 (sudo cpupower frequency-set -f 2.2G)

    现在运行cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq 会显示 2200000

4) 现在的BIOS power management 设置如下:

  • CPU Power Management -> OS DBPM
  • Memory Frequency -> Maximum Performance
  • Turbo Boost -> Disabled
  • C1E -> Disabled (When set to Enabled, the processor is allowed to switch to minimum performance state when idle)
  • C States -> Disabled (C States allow the processor to enter lower power states when idle)
  • Collaborative CPU Performace Control -> Enabled
  • Uncore Frequency -> Maximum
  • Energy Efficient Policy -> Performance 

但是, 如果使用 watch -n 1 "cat /proc/cpuinfo | grep MHz"  来监测CPU频率的话, 会发现频率是实时变化的 (用 i7z 来看也是一样的). 当且仅当负载上去之后 (比如用stress -c 40) CPU的频率才会稳定在2.2GHz.

为了做研究我必须要让CPU频率锁定(在我自己的台式机上是可以实现的),请问在这台服务器上怎么锁住频率?

0 项奖励
社区管理员
社区管理员

回复: 如何在R730xd上锁定CPU主频?

Hi, 硬件层面我看到您已经禁用了超频、C1E、C States等,除此之外我们也暂时没有更好的方法提供给您。建议您可以到intel以及系统相关的论坛去查找一下,看看是否有相似的案例或者相应的建议。

0 项奖励
MaoJun
1 Copper

回复: 如何在R730xd上锁定CPU主频?

我们也遇到类似的问题,关闭睿频也不行。但是hp的服务器就完全没问题。

0 项奖励
版主
版主

回复: 如何在R730xd上锁定CPU主频?

不是这样的,有时候和服务器类型无关和BIOS版本或者操作系统有关。 https://www.cnblogs.com/276815076/p/5434295.html 可以看看这个文章,人家是用内核工具锁定的。
--------------
巡视 斑竹
-------------
0 项奖励
版主
版主

回复: 如何在R730xd上锁定CPU主频?

您可以看看我介绍的那个文章,我建议的步骤是首先修改CPU工作模式,然后再绑定频率,光绑定频率是没有用的。
--------------
巡视 斑竹
-------------
0 项奖励