1 Copper

Re: PowerEdge T320 iDrac physical disk status unknown

Are there any other recommended troubleshooting steps for this issue? We have an R430 with an H310 controller that is showing this shame issue, along with some other hosts.

The WS-Man request for the DCIM_ControllerView (as well as the racadm and other means of getting the status, including via the iDRAC system inventory page) show a PrimaryStatus of Unknown (numerically where appropriate=0). According to the documentation, this uknown status is intentional, but it's not clear on what conditions give way to it.

Some things we've tried:

1) All firmware up to do (and re-installed twice).

2) Inventory Collection on Restart is enabled.

3) We have a 4 disks attached to the controller. We switched between RAID mode and HBA mode, with no effect. We created a virtual disk with 2 out of the 4 controllers (back in RAID mode), thinking this might initialize some obscure data structure, with no effect. Is there something regarding this we are not aware of?

4) We unplugged the system for 30 minutes, and plugged it back in.

5) We conducted both hard and soft rac resets.

6) We've followed the hacky solutions posted by other users, like resetting the iDRAC and simply looking at the controller/disks in both the configuration utility and the lifecycle controller.

The only thing we haven't tried, is taking these servers apart and physically reconnecting the H310 card or messing with jumpers.

There are at least a dozen posts regarding this set of issues, and none of them provide an account of a root cause. Can we get a more comprehensive answer?


0 Kudos