bacarlino
1 Copper

XPS 9560 Audio Controller

My 9560 is struggling to detect the "audio controller".

 

In Windows it says that that device fails to start.

In Linux it will say there are no soundcards detected.

In ePSA I don't hear the 6 beeps.

 

Occasionally if I do a full shut down and boot up cold, it will work for a while as long as I don't allow the system to hibernate... that kills the audio it every time.

I have replaced the "audio daughter-board" thinking this was the "audio controller", but the results are identical. Is this a problem with something on the motherboard? (system board in the docs). Is there anybody here at all that knows what might be going on and what I need to do?

I'm extremely irked that a 2 year old $1,850 laptop, now out of warranty, would have such a crippling issue. At this price point, I'm becoming convinced to never buy another Dell again. I talked myself away from a Macbook for this, perhaps I shouldn't have.

0 Kudos
Saltgrass
4 Germanium

Re: XPS 9560 Audio Controller

When you open the Device Manager and look at the Sound device, does it show up all the time or does it disappear when the system is not working correctly.

If it isn't visible, does it show if you set the view to show hidden devices?

Does it make any difference whether you are using internal speakers or a wired headset?

Do you have a Bluetooth headset you could try?

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
erpster05
2 Iron

Re: XPS 9560 Audio Controller

try installing the latest Realtek audio driver (v6.0.1.8622 A14), which was released on May 16th.  restart the computer after installing this Realtek audio driver package.

if this updated driver still does not provide audio, then the onboard audio controller on the XPS 9560 system board may be faulty and the entire motherboard may need replacement

0 Kudos