1 Copper

DELL Precision 7730 GPU power problems in Ubuntu | Manjaro

While researching what seems to be Manjaro specific extremely low performance on battery problem
i believe i've found power-related bug which is universal to my setup and most likely nvidia driver related, checked it on Ubuntu (which DELL claims to "officially support") - also happens there.

1. After boot on AC
Heavy load Graphics 1708 mHz / Memory 7230 mHz
FAN can go REALLY hard on any load

2. BAT
Heavy load Graphics 427 mHz / Memory 7230 mHz
FAN doesn’t go REALLY hard on any load

3. After switchin back to AC
Heavy load Graphics 427 mHz / Memory 7230 mHz

By heavy load i mean games like Native Hitman 2016, 3D modeling, 4k video...Well all the usual stuff that should crank CPU/GPU.

If you just load on AC everything is fine, clocks can go max, but any battery/AC swtich cause this to not recover max performance until reboot.

In short in manjaro thread i've tried disabling tlp, powermizer, forcing tlp to full max, forcing powermizer to max etc - nothing changes this behaviour.
So i suspect this bug could possibly be connected with Manjaro performance problem, but after trying Ubuntu i guess this is separate nvidia driver related issue.

Now i'm on clean dualboot Ubuntu 18 LTS / Manjaro Deepin, updated and installed latest Nvidia 415.27
Here's my system specs. inxi -Fxxz

    System:    Host: x133-pc Kernel: 4.19.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Deepin 15.9 tk: Qt 5.12.0 
               wm: DeepinWM dm: LightDM Distro: Manjaro Linux 
    Machine:   Type: Laptop System: Dell product: Precision 7730 v: N/A serial: <filter> Chassis: type: 10 serial: <filter> 
               Mobo: Dell model: 0VC5H3 v: A00 serial: <filter> UEFI: Dell v: 1.5.2 date: 11/01/2018 
    Battery:   ID-1: BAT0 charge: 94.1 Wh condition: 94.1/97.0 Wh (97%) volts: 12.9/11.4 model: BYD DELL GW0K986 serial: <filter> 
               status: Full 
    CPU:       Topology: 6-Core model: Intel Core i9-8950HK bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
               flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 69720 
               Speed: 800 MHz min/max: 800/4800 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 
               9: 800 10: 800 11: 800 12: 800 
    Graphics:  Device-1: NVIDIA GP104GLM [Quadro P5200 Mobile] vendor: Dell driver: nvidia v: 415.27 bus ID: 01:00.0 
               chip ID: 10de:1bb5 
               Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 3840x2160~60Hz 
               OpenGL: renderer: Quadro P5200/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
    Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
               chip ID: 8086:a348 
               Device-2: NVIDIA GP104 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1 
               chip ID: 10de:10f0 
               Sound Server: ALSA v: k4.19.16-1-MANJARO 
    Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
               chip ID: 8086:15bb 
               IF: eno1 state: down mac: <filter> 
               Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: 3000 bus ID: 6f:00.0 chip ID: 8086:2526 
               IF: wlp111s0 state: up mac: <filter> 
    Drives:    Local Storage: total: 267.35 GiB used: 36.56 GiB (13.7%) 
               ID-1: /dev/nvme0n1 vendor: Samsung model: PM981 NVMe 256GB size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
               serial: <filter> 
               ID-2: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 28.88 GiB serial: <filter> 
    Partition: ID-1: / size: 54.30 GiB used: 7.70 GiB (14.2%) fs: ext4 dev: /dev/nvme0n1p3 
    Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 52 C 
               Fan Speeds (RPM): cpu: 0 fan-2: 0 
    Info:      Processes: 264 Uptime: 1m Memory: 62.75 GiB used: 988.0 MiB (1.5%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
               Shell: bash v: 5.0.0 running in: deepin-terminal inxi: 3.0.30

My configuration:

Precision 7730

I've repeated above steps 1-3, then sudo startx -- -logverbose 6 and


Here's what i've already tried in this thread:

Labels (2)
0 Kudos