ahill1989
2 Bronze

Permission not copying during migration

Their is a deep directory structure and 4 layers down or 8 layers down the directory structure there are some files and directories which do not have administrator permissions  and only the owner has permission . Due to this when we copy Data these folder and files throw access denied errors. The Major challenge is to find these files and directories and change  their permissions and run the copy again , this difficult task as their are thousands of files per directory . does anyone have a script or an idea on how to easily solve this problem?

0 Kudos
Peter_Sero
4 Beryllium

Re: Permission not copying during migration

The PermissionRepair job directly on the Isilon might help, but sets all ownerships and permissions identical.

If that is not what you want, the classic UNIX commands find, chmod and chown should do it; the exact script would depend on what is actually needed.

-- Peter

View solution in original post

0 Kudos
ahill1989
2 Bronze

Re: Permission not copying during migration

Thanks, this helps a lot.

0 Kudos
uid_0
2 Bronze

Re: Permission not copying during migration

Is this using SMB shares of NFS exports?

If you're using SMB - I usually create a hidden share just for migrations.  I give select accounts "run as root" share permissions (in the SMB shares settings for the share).  I only use this share for file copy/migration purposes.

On the Isilon - If you're trying to copy over owner information, you'll get access denied when trying to set the owner unless the account has run as root perms on the share.