s.pop's Posts

s.pop's Posts

Thank you for your suggestions. I have encountered many issues but here is what worked to get to the point of using the information you have provided. I have changed the SSD from slot 0 to slot 1... See more...
Thank you for your suggestions. I have encountered many issues but here is what worked to get to the point of using the information you have provided. I have changed the SSD from slot 0 to slot 1 and put the original HDD into the 0. This allowed me to get win7 installed. I am currently at this point and will follow your advice. Many thanks.
I'm a very patient guy but I'm getting to the boiling point with this laptop. I've got a good deal on this M17x R3 laptop from a coworker since he wasn't using it but he said I will need to giv... See more...
I'm a very patient guy but I'm getting to the boiling point with this laptop. I've got a good deal on this M17x R3 laptop from a coworker since he wasn't using it but he said I will need to give it a fresh Win install since it hasn't been used for long and got sluggish and slow. It booted up, I checked it out and got it on the desk. Installed 16GBs of RAM, 250 SSD and thought that it's impossible not to have updated drivers for Win10 since it's a 2011 machine. Well, I installed Win10, nothing worked right and went on to Install the Original Win7 Home Prem that I have downloaded in multiple builds/versions. I'm getting errors on all my attempts. I've managed to install a Win7 Ultimate and still some drivers were not proper. I don't have the original Win disk neither does the previous owner. I'm using bootable USB drives - I have used 3 different ones SanDisk and "no brand name" to no avail. I have downloaded the drivers from the Support page based on the Express Service Code from the back of the laptop. Please advise since I've spent multiple days hunting for the solution that I know is out "there". Many thanks. S. Pop