salanglo's Posts

salanglo's Posts

OK, so Dell says that they won't support TB3 with an Apple device. What about their own devices? I have a TB16 that's suppose to work with the XPS 15 9550. However when I tried to call for support on... See more...
OK, so Dell says that they won't support TB3 with an Apple device. What about their own devices? I have a TB16 that's suppose to work with the XPS 15 9550. However when I tried to call for support on the TB16 Dell wouldn't even talk to me because my XPS 15 was no longer under warranty! Has anybody got the TB16 to actually work with an XPS 15 9550 and if so how? Sorry - not trying to hijack your thread but just venting about Dell's lack of TB3 support on the XPS 15 9550.
I've also got an XPS 15 9550 and I can't get it to recognize the TB16, I plug it in and nothing happens. I'm convinced that the current Thunderbolt firmware support at NVM 16.0 is to blame. I've post... See more...
I've also got an XPS 15 9550 and I can't get it to recognize the TB16, I plug it in and nothing happens. I'm convinced that the current Thunderbolt firmware support at NVM 16.0 is to blame. I've posted detailed descriptions of this problem on this forum and I haven't got any response from Dell. This is very frustrating that Dell won't support this product!
My cable has the Thunderbolt symbol also. I wish someone from Dell would help and look into this. When I called support they wouldn't talk to me because the warranty had expired  on my XPS 15 9550! S... See more...
My cable has the Thunderbolt symbol also. I wish someone from Dell would help and look into this. When I called support they wouldn't talk to me because the warranty had expired  on my XPS 15 9550! Support wouldn't discuss the TB16 that I had just purchased. I was able to get Dellcares to replace the original TB16 but the replacement acts exactly the same as the original and won't connect. ! purchased my XPS 15 9550 in November 2015 - Dell should just admit the TB16 doesn't work with and isn't supported with early XPS 15 9550's!
I can see in the BIOS you can allow all Thunderbolt devices but I don't see any option like this in the Thunderbolt software. Also what do you mean by 'reset my system' - reinstalling Windows? I've... See more...
I can see in the BIOS you can allow all Thunderbolt devices but I don't see any option like this in the Thunderbolt software. Also what do you mean by 'reset my system' - reinstalling Windows? I've been using a USB-C to DIsplayport adapter for over a year. I remember the system asking some question when I first plugged it in but I don't remember the question or what I replied. I'm wondering if the USB-C port somehow is now reconfigured as a 'Display Port over USB-C' type connection and now won't work with the Thunderbolt only cable.in the TB16? The following is from the 'How to Use and Troubleshoot the Dell Thunderbolt Dock (TB16)' - NOTE: The Dell Thunderbolt dock will not function on a device with Display Port over USB Type-C with the current Thunderbolt only cable. Future Dell Docking Station Connector cables for the Dell Thunderbolt Dock will be a universal USB Type-C /Thunderbolt 3 compliant, allowing the dock to connect to either Display Port over USB Type-C or Thunderbolt 3 ports.
I'm having issues getting the TB16 to work with the XPS 15 9550. I successfully installed all the drivers in the proper order as documented prior to plugging in the TB16 for the first time. I've ... See more...
I'm having issues getting the TB16 to work with the XPS 15 9550. I successfully installed all the drivers in the proper order as documented prior to plugging in the TB16 for the first time. I've verified that I indeed do have a Thundrerbolt port - there is a Thunderbolt symbol next to the USB-C port. When I do plug in the TB16 the power button on it will power the system off/on. I've used a usb-c to Displayport adapter and a usb-c to usb 3.0 adapter with a flash drive. Both worked successfully so the basic functionality of the usb-c port is working. When I plug in the TB16 I never got an authentication window pop-up. In the Thunderbolt software it shows no attached devices. The details setting in the Thunderbolt software looks fine, it appears to have the proper driver and firmware levels. When I check the Thunderbolt driver it says that 'the hardware device is not connected to the computer'. I'm at a loss - everything looks good except for the fact that nothing happens when I plugin the TB16. I'm wondering if there's a hardware problem with the Thunderbolt controller itself? I'd appreciate any help that anyone can give me.
1. My XPS 15 does have a Thunderbolt 3 controller. 2. The BIOS and all drivers were updated as recommend in the 'How to use and Troubleshoot the Dell Thunderbolt Dock (TB16)' prior to attempting to... See more...
1. My XPS 15 does have a Thunderbolt 3 controller. 2. The BIOS and all drivers were updated as recommend in the 'How to use and Troubleshoot the Dell Thunderbolt Dock (TB16)' prior to attempting to use the dock.
I'm having problems getting a TB16 dock recognized on my XPS15 9550. I updated the BIOS and the drivers indicated in the Dell Thunderbolt Dock TB16 user guide. I connected the AC adapter to the TB16 ... See more...
I'm having problems getting a TB16 dock recognized on my XPS15 9550. I updated the BIOS and the drivers indicated in the Dell Thunderbolt Dock TB16 user guide. I connected the AC adapter to the TB16 and then connected the Thunderbolt 3 Type-C cable to the XPS 15. The Thunderbolt icon appears in the system tray but - 1. I get no authentication window to select the user setting. 2. When I right click on the Thunderbolt icon to view attached Thunderbolt devices there are none. 3. Of course no devices attached to the TB16 are visible on the XPS 15. Attached Devices - Thunderbolt Details - I have been previously using a usb-c to Displayport adapter with no issues. Also the power button on the TB16 does power down the XPS 15. I guess it could be a hardware problem with the TB16 but I'm hoping somebody has seen this and has a solution. Thanks, Steve