Reply to Message

Reply to Message

View discussion in a popup

Replying to:
DMK111
1 Nickel

RE: E7450 SCCM Build

Hi Sreejith,

When using SCCM OSD, it basically fails when setting up operating system. I have found that it first fails with the heci.inf driver (3TY1R). Sorted that issue out, by rearranging the files and folders, like how it was setup in the CAB for E7440 driver pack. But I am getting the same failures again, and found that it was by DPTF drivers (66P3R). I excluded DPTF from the build and has completed fine. However, I ended up with two items in device manager with missing drivers (Yellow bang). They are:

 

If I manually update these two items with the extracted INF drivers, I then get:

I don't get 5 items, as apparently it does in Win8.1 machines. (I am on Win7 x64).

I then tried to run “Chipset_Driver_66P3R_WN_8.0.10002.14_A00.EXE”.

I get the error:

And Device manager ends up like this:

If I try to update the driver via the INF file again with the unknown device, I get this error:

 

Hence, I think I have an issue with the driver esif_manager.inf, which seems to be the one that is failing to install.

I don't know how to read the INF file, but I am suspecting some files maybe missing from this driver pack.

Looking at esif_manager.inf, I see this section:

[EsifLf_InstallService] ServiceType    = %SERVICE_KERNEL_DRIVER% StartType      = %SERVICE_DEMAND_START% ErrorControl   = %SERVICE_ERROR_NORMAL% ServiceBinary  = %12%\esif_lf.sys LoadOrderGroup = Base

[WUDFRD_InstallService] DisplayName    = %DisplayName% ServiceType    = %SERVICE_KERNEL_DRIVER% StartType      = %SERVICE_DEMAND_START% ErrorControl   = %SERVICE_ERROR_NORMAL% ServiceBinary  = %12%\WUDFRd.sys

 

WUDRFd.sys. I don't see this file in my driver.

 

Having said all this, I think I have just fixed the problem.

I am posting this anyway, for anyone else who might have this problem.

Looks like WUDFRd.sys is related with UMDF framework. I installed this manually and tried to install the driver pack "Chipset_Driver_66P3R_WN_8.0.10002.14_A00.EXE" again, and all got installed ok this time without error.

I will now try to inject UMDF into the OSD Task Sequence, and hopefully all will go well this time.

DM

0 Kudos