Reply to Message

Reply to Message

View discussion in a popup

Replying to:
sevenredlines
1 Copper

RE: E7450 SCCM Build

Hello Friends,

We've tried almost everything in this forum post, as well as the related ones and so far we're hoping for the new working Intel/Dell driver to show up.

On the fourth page of this thread, DELL-Sreejith D (on 10 Apr 2015 at 2:14 AM) said Dell was working with Intel on the new version of the NIC driver or cab for the Dell Latitude E7450/E7250 which has the l217/l218 Intel NIC.

It doesn't seem this new version has shown up on the Dell Support site or this thread (please correct me if I'm wrong!). Sreejith do you have an update for this issue?


I'm new to SCCM2012 (and SCCM in general) but here is the background of our problem:

The beginning of this driver adventure for us was trying to PXE boot a brand new Latitude E7250 after importing the lates Dell.cab into SCCM2012 and no network drivers were found when PE loaded. We are installing Windows 7 x64 Enterprise. That led us to this article: www.dell.com/.../en

We have not been able to locate the referenced driver versions (12.12.50.4 or 12.12.50.7205) on Dell's site to use with our X86 WinPE boot image. Specifically, the e1d6432.inf driver. While I did find a copy of the intel NIC driver version 12.12.50.7205 on HP's website, when it is DRVLOAD, it will give you a 169.x.x address when you use IPCONFIG. At the moment we are not ready to create an x64 WinPE boot image and it is unclear if it would resolve this issue; so currently still working on making this work with an X86 WinPE boot image. In the above article it does point to using this cab en.community.dell.com/.../5029.winpe-5-0-driver-cab, but the contained driver for X86 does not work. You can see in the chart it says there is an update, "new driver release on support.dell.com" but there is no link or way to find it.

The work around we found in this thread and attempted to implement was to import the Intel's latest driver into SCCM2012. The intel driver carries the version number of 12.12.80.19, which SCCM will not import. To test if Intel's latest driver would work at all (get an ip) we used the "DRVLOAD e1d6432.inf" command from the f8 window after the WinPE enviroment loads but fails to load the network driver.. You notice when you do that the NIC power cycles and gets an IP address. If you run tsbootshell.exe, the task sequencer will pickup where it left off (when the NIC driver did not load) and complete.

I then went through every available Intel and Dell driver W7/W8/W8.1 and Intel and Dell .cabs I could find and did DRVLOAD process for each. This was the result:


dell original driver e7250\win8132\e1d6432.inf = power cycle and 169.x.x
dell original driver e7450\win8132\e1d6432.inf = power cycle and 169.x.x

dell w7 cab\windows7-x86\e1d6232.inf = nothing (en.community.dell.com/.../7936.latitude-e72507250-windows-7-driver-pack)

dell pe5 cab\windows8.1-x86\e1d6432.inf = power cycle and 169.x.x (en.community.dell.com/.../5029.winpe-5-0-driver-cab)

intel\cab cd\win32\ndis64\e1d6432.inf = power cycle and IP ADDRESS (downloadcenter.intel.com/.../Intel-Ethernet-Connections-CD)

intel\w7\prowin32\pro1000\win32\ndis64\e1d6432.inf = power cycle and IP ADDRESS (downloadcenter.intel.com/.../18713)

intel\win8.1\prowin32\pro1000\win32\ndis64\e1d6432.inf = power cycle and IP ADDRESS (downloadcenter.intel.com/.../Network-Adapter-Driver-for-Windows-8-1-)


We are using SCCM2012R2 on Server 2008R2. With the Windows 8.1 ADK with Win PE 5.1 (6.3.9600.16384) and the updated 1.11 Kernel Mode Framework.

Found this article about driver import issues with Server 2008R2 importing newer drivers that use the newer signing (Win 8.x) and applied the hot fixes listed, but the issue persists:
support.microsoft.com/.../3025419

This put in our mind SCCM2012R2 was having an issue DISM'in the intel driver which is why the import was failing. We tried a manual DISM (technet.microsoft.com/.../hh825070.aspx) to the WIM but ran aground with that process as well. I'm not sure if the manual DISM fail is realted to this article under the Windows PE5.1 Section, 2nd Paragraph: blogs.technet.com/.../understanding-the-adk-for-windows-8-1-update-and-configmgr-osd.aspx ; since we were running the Manual DISM on the SCCM2012R2 server.

I would love to hear any ideas on other ways to get this done, but especially hearing about the rumored new x86 driver that will import into SCCM2012 correctly.

Currently we're thinking about running a pre-task command to call to a .bat file to DRVLOAD the working intel driver once PE loads before the task sequence kicks off; not that we feel that is a great idea but would just like to get something working until new drivers show up.


Thanks for set of eye on this issue!

0 Kudos