Reply to Message

Reply to Message

View discussion in a popup

Replying to:
1 Nickel

Re: XPS 8700 Internet stopped working after windows update 1709

Are there any LEDs lit near the Ethernet connector on back of the PC?

Yes. I unplugged my cable and attached it to another PC. It works fine. I took their cable and attached it to mine. No internet. The lights work. I reset the router too. No luck.

Did you look in BIOS setup (reboot and immediately press F2) to make sure the onboard NIC is still Enabled?

Yes. I also toggled LAN boot ROM in the BIOS advanced settings as some other user suggested. That didn't help either.

Is the NIC still listed in Device Manager or did it disappear? Are there any "unknown" devices listed in Device Manager?

Yes. Realtek is listed

Have you tried uninstalling the NIC driver then reinstalling/updating the Intel chipset and AMT HECI drivers, rebooting and then install the NIC driver again? Unless the chipsets are correctly installed, other drivers may not install or may not work.

Yes, I uninstalled and reinstalled the Realtek drivers to the latest and the version before. But that didn't help. I didn't try uninstalling/reinstalling the chipset drivers. The drivers from Dell's site seem quite old for the 8700's chipset. Anyway, I tried reinstalling them both. No luck.


All I am left now is to reinstall Windows 10 from an ISO image that I found on Microsoft's site.

0 Kudos