Reply to Message

Reply to Message

View discussion in a popup

Replying to:
KarthickSriram
1 Nickel

Touchpad gestures not working Code 10 error: I2C HID Device

I own a dell G7-7588 laptop and recently my touchpad gestures have failed to work. When I open the device manager, I get an exclamation mark next to the I2C HID Device. I tried uninstalling the driver and restarting the lapop. The computer searches itself the drivers and installs. The multitouch gestures works fine for a while after which it fails again. If I go back to the device manager, I get to see the exclamation mark present next to I2C HID device. I tried uninstalling and reinstalling the Intel IO serial drivers as they are the drivers containing the touchpad. The method works for once and when I restart the computer, the touchpad gestures do not work. I tried checking for updates and nothing were available. I tried checking using the dell update as well. The error in device manager is: This device cannot start. (Code 10). A request for the HID descriptor failed.

I tried reinstalling the device drivers and it does not install giving an error that the device failed to start. But the touchpad is working fine and there is no failure.

It does not seem to be like a hardware issue as the touchpad works perfectly and its just the gestures. There are no separate touchpad drivers for Dell G7 and the touchpad menu is not available in additional mouse settings.

There is not any extra option available in the touchpad menu of the windows settings as well. I do not think it is possible to uninstall and reinstall the drivers everytime I reboot the computer. There are no touchpad options in the bios settings as well. I have tried the registry edit option of changing upperfilter registry. There is no luck with that as well. If there are any suggestions to make it work, then it would be useful.

 

asdasdasdad.PNGScreenshot (6).pngScreenshot (7).pngasdasdad.PNG