Reply to Message

Reply to Message

View discussion in a popup

Replying to:
thumpabar
1 Copper

Re: DELL U2713HM not USB 3.0

This thread is kind of old and this post is kinda long, I know, but I am having all sorts of issues with this USB3 hub on a new Haswell system which ONLY has USB3 ports.

With the original A01 revision U2713HM, and a freshly built Win7 x64 on all new hardware, it kept disconnecting/reconnecting every 10 or so seconds and would not stay connected no matter which port it was plugged into.

I called Dell and a A00 revision U2713HM was sent out as a replacement.  This one kind of worked, in that it would detect my USB3 HDD & USB3 32Gb Stick no issues...the webcam however would no longer work AT ALL when plugged into the monitors USB3 ports.  Plugged into the PC direct and no issue.

I noticed that it actually had a "USB 3.0 Hub" and another "Unknown Device" installed in the device manager.  I put back the A01 revision monitor (which had all the devices detected) and did some playing around with the drivers for the USB Hub in Device Manager.

After lots of messing around and many reboots I managed to get a "USB 3.0 Hub" loaded and working, instead of the "Generic USB Hub" that it had previously, or a Hub that had the yellow exclamation because it couldn't start.  It stays connected no problem now, but it is only running at USB 2.0 speeds & won't power the webcam or USB3 HDD 😞

If I use the "Generic USB Hub" driver, there are 4 ports with 500mw max for each port, which you can see in the "Power" section of the Properties of the "Generic USB Hub" device.  If you update the driver to the Intel "USB 3.0 Hub" driver, you have no such tab any more.

I suspect if you can find the right combination of drivers...being proper USB 3.0 supported drivers, then the USB ports will work just fine.  It is just a shame that they generally don't get detected correctly due to a spec mismatch or whatever?

I am still struggling to get them right and to accept more voltage/wattage with the current "USB 3.0 Hub" driver as now the USB3 HDD spins up, but doesn't have enough power to keep the drive spinning and it see it properly in Win7.  The Webcam & USB3 32Gb stick work no problem and run at full speed.

I know the HDD works fine as it worked on the replacement A00 and works no issue plugged into the PC directly.

Anyways...anyone else found anything similar?

0 Kudos