Reply to Message

Reply to Message

View discussion in a popup

Replying to:
Moderator
Moderator

Re: PERC H700 predictive failure continues with new drive

I don't see a puncture in those logs. It looks like they go back to 11/30/2018. During the rebuild the controller is encountering a lot of bad blocks on the virtual disk. Here is a snippet of what is occurring several times during the rebuild.

02/03/19 14:49:52: MedErr is for: cmdId=9a, ld=1, src=1, cmd=1, lba=247eb8, cnt=8, rmwOp=0
02/03/19 14:49:52: ErrLBAOffset (1) LBA(123f38) BadLba=123f39
02/03/19 14:49:53: EVT#23597-02/03/19 14:49:53: 113=Unexpected sense: PD 03(e0x20/s3) Path 5000c5003bdfcb99, CDB: 28 00 00 12 3f 3a 00 00 06 00, Sense: 3/11/00
02/03/19 14:49:53: Raw Sense for PD 3: f0 00 03 00 12 3f 3b 0a 00 00 00 00 11 00 81 80 00 97
02/03/19 14:49:53: DEV_REC:Medium Error DevId[3] devHandle f RDM=806cba00 retires=0
02/03/19 14:49:53: MedErr is for: cmdId=9a, ld=1, src=1, cmd=1, lba=247eb8, cnt=8, rmwOp=0
02/03/19 14:49:53: ErrLBAOffset (1) LBA(123f3a) BadLba=123f3b

I'm decent at reading logs, but I don't know what everything in the log means. We do not have detailed documentation on the logs.

I think 247eb8 is the LBA address on the physical disk. In the ErrLBAOffset, the first LBA is the good or expected LBA. The second LBA is the returned value that is in error. The (1) is the offset value or difference between the two.

The sense key or key code qualifier is 3/11/0, medium error - read retries exhausted.

What I think is happening, information is being copied to the drive during the rebuild. During the verification process it is reading physical disk logical block address 247eb8. It is expecting virtual disk LBA 123f38 to be written in that block but 123f39 is there instead. After the read retries are exhausted it moves onto the next logical block. It tries to copy another virtual disk LBA to the same physical disk LBA and encounters the same error.

I can't say with certainty whether or not the virtual disk or physical disks are at fault since I'm not seeing the same bad blocks on more than one disk. I didn't check all of the blocks though. I would run diagnostics on the disks. If the disks are shelf spares that have been sitting for a long time or were received in the same shipment then they may be faulty.

Daniel Mysinger
Dell EMC, Enterprise Engineer

Get support on Twitter @DellCaresPRO