Reply to Message

Reply to Message

View discussion in a popup

Replying to:
tfnico
1 Nickel

[XPS 9360 DE] Kernel 4.9 fixed my suspend problems

I have the following setup:

  • XPS 13 9360 (dev edt. with touchscreen)
  • Ubuntu 16.04.1 LTS (as shipped, with updates)
  • BIOS updated to 1.2.3
  • Kernel was the latest 4.4 (as shipped, updated to 4.4.0.57)
  • Problem was as follows:

After being connected (and disconnected) from external display with mDP (via WD15 adapter in the USB-C slot), it would fail to resume from suspend. Screen would stay black, keyboard lit up but did nothing, only thing to do would be to power off by holding the button.

After booting again, syslogs showed only the suspend had taken place (with some warnings and stuff, I was unable to relate whether any of these had to do with the crash), and then the next log entry would be the next boot after hard reset.

Note that otherwise suspend and resume worked fine on the laptop. Only when it had been connected to my external display it would start this behavior. Another way to trigger it was to connect the USB-C/mDP, suspend, and then unplug. The laptop would also fail to resume from that state.

I now just tried the recently released 4.9 kernel, and although I haven't tested it for long, the problem above in particular seems to be resolved. Not sure if it introduces any new problems though (it does seem like it now makes little pauses when loading files some times).

I know this is a bit like stating that this cannonball killed that sparrow, but in case anyone else is looking for a workaround for this really annoying problem, there it is.

Tags (1)
0 Kudos