Dell-Matt-E
2 Iron

License Count Exceeded

Jump to solution

I have a customer that has a 7.1 environment that consists of a Windows 2008 R2 server running the broker service and a Windows 2008 R2 server running the RDS role. The environment is licensed with a 5 User Enterprise and EOP license, however when they connect to an RDS session it goes through the logon process and then displays the 'License count was exceeded' error although know one else is logged on. I have see this before but can't recall the fix, I also search SupportLink with no success.

0 Kudos
1 Solution

Accepted Solutions
DELL-Andrew W1
3 Argentium

RE: License Count Exceeded

Jump to solution

Hello Matt,

Last time you logged this issue, it runed out to be a problem with IPv6.

IPv6 had been disabled but AFTER an IPv6 address had been registered in DNS.

What would happen is the RDS would get the IPv6 address for the Connection Broker so effectively couldn't check how many licenses were available.

Removing the IPv6 entries from DNS fixed the issue.

Thanks, Andrew.

P.S This is one cause for the issue - there can be more reasons !

View solution in original post

3 Replies
DELL-Andrew W1
3 Argentium

RE: License Count Exceeded

Jump to solution

Hello Matt,

Last time you logged this issue, it runed out to be a problem with IPv6.

IPv6 had been disabled but AFTER an IPv6 address had been registered in DNS.

What would happen is the RDS would get the IPv6 address for the Connection Broker so effectively couldn't check how many licenses were available.

Removing the IPv6 entries from DNS fixed the issue.

Thanks, Andrew.

P.S This is one cause for the issue - there can be more reasons !

View solution in original post

RE: License Count Exceeded

Jump to solution

Hi Matt,

Just to second Andrew, I had this last week and I had to go around editing the following registry key.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\DisabledComponents = 20 (REG_DWORD)

Paul

0 Kudos
hbui-sbcpro.de
2 Bronze

RE: License Count Exceeded

Jump to solution

Paul,

i think normally the OS tries IPv6 addresses in front of IPv4 addresses. With this flag you just reversed the order (there is a table to control the order that various DNS sources are checked, this setting changes the values in that table).

If it is the case that IPv6 had been really disabled than it may be a better solution to go and clean the table of the DNS server/s as Andrew mentioned.

Holger

0 Kudos