geldd001
1 Copper

RDP Language settings solution

We had problems to solve the language settings in a RDP session. The default language is always the language of the device the RDP session is running on. That means in our case a dutch VDI desktop with default english language. The thinclients are XP embedded with a dutch language layer. So the thinclient is default with English language. After searching for a very long time I found the tool Setlocale. With some parameters you now can use it scripted in vWorkspace to set the language you want.

Hope it will help someone..

Best Regards

Danny

0 Kudos
5 Replies
DELL-Robb S
2 Bronze

RE: RDP Language settings solution

I have not had to combat that issue however I did have a client call center operation where the users support various customers.  In this arena the users were on pc's where the local regional time was Australia/Sydney and they need to get virtual desktop regional settings to the customer's locale...So pulling the local region would always give them Australia/Sydney time zone.  We recommended they use the time zone setting in vWorkspace to resolve.

0 Kudos
hbui-sbcpro.de
2 Bronze

RE: RDP Language settings solution

Danny,

I also havn't had to combat such an issue directly so far, but i do like the idea of this tool. At first glance I think it could be useful for none vWorkspace environments. In vWorkspace environments itself my viewing of the included readme file is telling me that i would tend to use a registry task without the provided tool in vWorkspace to set the needed keys. Did i catch this possibility wrong?

Btw at first i thought it would be a solution for the issue i ran into a while ago. I am from Germany and used to have a local german keyboard layout. As i was out to a friend within the UK i tried to check for my open tasks, but wasn't able to logon to my session because back home i choosed to use a german only character within my password 🙂 At last i was able to logon by setting the german keyboard layout on my friends notebook.

I guess for this issue the tool as well as the registry setting in vWorkspace wouldn't help at all because in my opinion those settings wouldn't be active as soon as the logon screen appears.

Holger

0 Kudos
DELL-David Y
3 Argentium

RE: RDP Language settings solution

Holger,

You may be able to use the followig registry edit for the issue that you have described.

    HKLM\System\CurrentControlSet\Control\Keyboard Layout

    DWORD   "IgnoreRemoteKeyboardLayout"

   

To enable use a value of 1 and a value of 0 to disable.

When enabled the remote session ignores the keyboard layout of the connecting client, reverting to the system default setting.

0 Kudos
geldd001
1 Copper

RE: RDP Language settings solution

Hello Holger,

You can set the regkey using the Resources Script.

I tested it and we use it now for our thinclients. Works like a sharm. I think it is usefull because as you say, you could use it in different ways. Maybe it could be done in more ways but after searching for a long long time, this was working and all the other solutions didn't worked out.

0 Kudos
hbui-sbcpro.de
2 Bronze

RE: RDP Language settings solution

David, thanks for this hint. I am going to post this to our german vWorkspace forums too. Hope it will be of use for some more people. Thanks again, Holger.

0 Kudos