Highlighted
2 Iron

Remote desktop logon settings - load balance

Jump to solution

Hello,

I have the following question:

I'm settinga up a farm of remote desktop servers using a vWorkspace with one connection broker in front.

What is your suggestion for load balancing a remote desktop connection.

Based on my testing an application load balancig is working fine because it is connecting to vworkspace farm, but with desktop connection, using a quest vWorkspace client, there is no option to specify vWorkspace farm. If I use an dns roundrobin, then I have (sometimes) an issue with roundrobin itself, redirecting me to the wrong remote desktop session host.

Is there any workaround?

Thank's in advance.

Regards, Robert

0 Kudos
1 Solution

Accepted Solutions
Highlighted
3 Argentum

RE: Remote desktop logon settings - load balance

Jump to solution

Hello Robert,

Have you created any managed applications in the vWorkspace Console, configured under the resources tab?

If not, then create a managed application that is published to all the RDS host servers and assigned to your users.

On your client, select the application radio button on the General tab. The drop-down list above this will then display the managed applications the user has access to, there is no need for you to enter a host IP address or use a DNS round-robin.

With this configuration the user will be connected to one of the RDS host servers for their initial connection, the broker will determine the most suitable host given the current load evaluation on each server.

If the user becomes disconnected from the session they can reconnect by launching the application, the broker will then identify the user has a disconnected session on one of the RDS host servers and reconnect the user.

Regards

David

View solution in original post

6 Replies
Highlighted
3 Argentum

RE: Remote desktop logon settings - load balance

Jump to solution

Hello Robert,

When you say 'but with desktop connection, using a quest vWorkspace client, there is no option to specify vWorkspace farm' how are you making the connection?

On the General tab you can select the Connectivity option and then specify your vWorkspace farm, is this what you are looking to do?

Capture.JPG

Regards

David

0 Kudos
Highlighted
2 Iron

RE: Remote desktop logon settings - load balance

Jump to solution

That's I already try. On General -> Logon setting I entered an RDS host IP address and undre connectivity -> server list IP of connection broker. In that setup I always get connected to the same RDS host.

The second option I try is to enter a roundrobin A record for my RDS host to General -> Logon setting. Connectivity -> server list stay the same. In this setup I get a load balanced connection between my two RDS host, but there is an issue with reconnect to the disconected session in some circumstances (DNS roundrobin design).

Resolution in my opinion, would be if I could dedicate an IP to farm  configured in vWorkspace management console, or am I missing that setting somewhere?

Regards, Robert

0 Kudos
Highlighted
3 Argentum

RE: Remote desktop logon settings - load balance

Jump to solution

Hello Robert,

Have you created any managed applications in the vWorkspace Console, configured under the resources tab?

If not, then create a managed application that is published to all the RDS host servers and assigned to your users.

On your client, select the application radio button on the General tab. The drop-down list above this will then display the managed applications the user has access to, there is no need for you to enter a host IP address or use a DNS round-robin.

With this configuration the user will be connected to one of the RDS host servers for their initial connection, the broker will determine the most suitable host given the current load evaluation on each server.

If the user becomes disconnected from the session they can reconnect by launching the application, the broker will then identify the user has a disconnected session on one of the RDS host servers and reconnect the user.

Regards

David

View solution in original post

Highlighted
2 Iron

RE: Remote desktop logon settings - load balance

Jump to solution

Hello David,

That exactly is a resolution to witch I came about in morning when

discussing with my friend. That way RD session will be started thru

vWorkspace connection broker and will be aware of user disconnected session

on any RDS host.

Just let me test and I will post a results.

Regards, Robert

On Mon, Dec 10, 2012 at 10:30 AM, David Young <

0 Kudos
Highlighted
2 Iron

RE: Remote desktop logon settings - load balance

Jump to solution

Hello David,

I can confirm, that resolution to my problem was publih a desktop as managed application. In this config load balancing is working as expected.

Regards,

Robert

0 Kudos
Highlighted
3 Argentum

RE: Remote desktop logon settings - load balance

Jump to solution

That's good to hear, glad it is now working for you

David

0 Kudos