vWorkspace

Last reply by 01-21-2015 Unsolved
Start a Discussion
2 Jasper
2 Jasper
172077

VWorkspace 8.0.1 Linux VDI Deployment

We have vWorkspace 8.0.1 VDI farm setup with mix of Windows and Linux machines. I have setup CentOS 6.5 Linux VDI setup with xrdp 0.7.0 and qdcsvc 7.7. Everything work well, no problem, but I was wondering if there are settings for the following use cases that can be adjusted somewhere:

- I logon to a physical WinPC-A and run the vWorkspace Connector as a domain-x\aduser1, I click on the published desktop CentOS6.5-VM. Xrdp launches, I use a local Linux account to successfully logon to the XFCE4 desktop - Great! Then I go to a WinPC-B and click on same the published desktop and I get the error: "There are no available computers to connect to at this time. Please report this message..." Is there a setting that will let me re-connect to the same session if I'm the same domain user, in this case domain-x\aduser1? I believe this worked when I used Windows.

- Is there a setting to auto log-off the local Centos users after specified time? I also believe this works in Windows.

Reply (1)
720

Hello,

You're correct that both these settings work in Windows.

For the session roaming to work with Windows, there is a setting that needs to be set in the vWorkspace Management Console - it's worth checking that this is set correctly for your Linux Desktop Group before we get too worried about the Windows vs Linux differences.

1. In your vWorkspace Management Console, drill down to your Linux Desktop Group.

2. Right Click on the Desktop group and select properties.

3. Click Client assignment

4. Make sure the Client assignment is set to User if you want the session to roam as you described.

As for the idle session timeout, this is controlled via Registry/GPO settings in Windows.

In Linux xRDP is does look like they are thinking about implementing it.

Have a look in your xrdp man page - mine is older than yours - they list

KillDisconnected
   IdleTimeLimit
  DisconnectedTimeLimit

but currently it says the settings are ignored. Maybe in your 0.7.0 version they honour them? worth a look! 

Thanks, Andrew

Latest Solutions
Top Contributor