DELL-Tiago B
2 Bronze

vWorkspace Linux Connector Ubuntu 10.04/10.10 - solving some issues

Hello All.

Just sharing some finds about the vWorkspace Connector on Ubuntu 10.

The first thing it happens is when you run the script.

It complains about not being able to install libboost_thread1.34*. When you hit "y" for trying to install automatically it then returns an error like:

"ERROR: package libboost-thread1.34* is not found, try to install it manually"

This happens because the version 1.34 of libboost_thread is not available anymore for Ubuntu 10, so you going to have to install the most recent one from apt-get, which is the 1.42.

So, you can install the connector with some workarounds because of usb-server component (read my last post about it).

After the installation you can successfully connect to the farm and list the applications, but when you try to launch a application you get an error like "could not connect to rdesktop".

This happens because the vWorkspace Connector is looking for two lib files with old versions that don't exist in the Ubuntu 10.

The first one is The current version in Ubuntu 10 is

The second one is The current version, as described above, is 1.42.

So to fix this and get a successful connection to your published applications from a Ubuntu 10 connector you should create a symbolic link to their old names, like this:

Enter in the libraries directory: cd /usr/lib

List the content of desired libraries: ls -la libboost_thread* OR ls -la libao*

You will see that for both files there is already a symbolic link called AND, both pointing to their respective current versions.

So you just have to create another link with the name that vWorkspace demands pointing to those existing links, like this:

ln -sv for libboost_thread library. AND

ln -sv for libao library.

Note that vWorkspace demands those libs with the names cited above.

If it is not clear enough because of my English (sorry about that) please drop me a note so I can provide furter help and instructions.

If anyone of you guys experience any install/execute/connection problems with Linux Connectors, specially for Ubuntu, please let me know.

I will be very glad to help you...


0 Kudos
4 Replies
2 Bronze

RE: vWorkspace Linux Connector Ubuntu 10.04/10.10 - solving some issues


thanks for your posting as I fight with the same issue but without to much success.

Maybe you have an idea.

I installed Ubunutu 10.04 LTS 64bit and vWorkspace Linux 7.0

qrdesktop shows:

  qrdesktop: error while loading shared libraries: cannot open shared object file: No such file or directory

checking the with ldd

  ldd `which qrdesktop` =>  (0xf76e5000) => /lib32/i686/cmov/ (0xf7574000) => not found => /usr/lib32/ (0xf74ab000) => /usr/lib32/ (0xf74a5000) => /lib32/ (0xf748c000) => /lib32/ (0xf7488000) => /lib32/i686/cmov/ (0xf7442000) => not found => /usr/lib32/ (0xf7420000) => /usr/lib32/ (0xf732a000) => /usr/lib32/ (0xf7326000) => /usr/lib32/ (0xf7209000) => not found => /usr/lib32/ (0xf71a9000) => /usr/lib32/ (0xf718a000) => /lib32/ (0xf7030000) => /usr/lib32/ (0xf701b000) => /lib32/ (0xf6ff4000) => /lib32/ (0xf6feb000)

    /lib/ (0xf76e6000) => /usr/lib32/ (0xf6fdb000) => /usr/lib32/ (0xf6fc1000) => /usr/lib32/ (0xf6fb8000) => /usr/lib32/ (0xf6fb3000) => /usr/lib32/ (0xf6fad000)

It seems there is a problem with 32bit / 64 bit libaries! qrdesktop uses 32bit but e.g. one of the missed libs is there but as 64-bit version:

     file /lib/

          /lib/ ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped


Interesting point, I can start the "vWorkspace AppPortal" and adding an XML file I got from my provider but can't connect.

is there a way to trace the connection setup?


0 Kudos
2 Bronze

RE: vWorkspace Linux Connector Ubuntu 10.04/10.10 - solving some issues

abort from the problem above. I can now start the AppPortal load a XML profile connect

and got a different error message:

[Error mkdir: kann Verzeichnis „/tmp/appportal“ nicht anlegen: Die Datei existiert bereits

00004]: Operation succeeded

[Module]: pntsc

[Description]:  Rdesktop error - Unable to connect to server.

sorry there is some german message there

the "Rdesktop error" is maybe a starting point.


0 Kudos
2 Bronze

RE: vWorkspace Linux Connector Ubuntu 10.04/10.10 - solving some issues

Hello Tiago,

I'm getting the similar error. I can launch my vWorkspace launcher from /usr/local/bin directory. Once I define my broker,login crdentials - it launches my application set- I can see my published desktop here. Once I click on that - it says Error 00004 System error, Module:pntsc, Descripton- Rdesktop error.

If I run ./qrdesktop - it says missing But this file is already there in .usr/lib directory and linked to What I'm missign here.

I tried downloading the file libao2_0.8.8-5ubuntu_i386.deb and while  installing it into my Ubuntu thinclient(T50) by using command sudo dpkg-i-force-all liabo2* or dpkg --force-architecture<package name>  It says error loading shared libraries.

Appreciate your help!


0 Kudos
DELL-David Y
3 Argentum

RE: vWorkspace Linux Connector Ubuntu 10.04/10.10 - solving some issues

Hello Bhim,

In your email it states that you are isntalling the Linux Connector onto your Wyse T50, were you aware that we have a specific installer package for this thin client?

Have you installed the vWorkspace Connector for Linux or the vWorkspace Connector for Linux Wyse T50 7.5?

Please follow this link for further details

There is also a Community thread with more information on this topic,



0 Kudos